Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to compile the Valve Source SDK (2007) on my machine, but I keep running into the same error:

In file included from ../public/tier1/interface.h:50:0,
             from ../utils/serverplugin_sample/serverplugin_empty.cpp:13:
             ../public/tier0/platform.h:46:17: new.h: No such file or directory

I'm pretty new to C++ coding and compiling, but using apt-file search I tried to use every single suggestion for the required files in the Makefile (libstdc++.a and libgcc_eh.a), and none worked. I then found a note in the Makefile saying gcc 4.2.2 is recommended - I assume the older code won't work with the newer version, but gcc-4.2 is unavailable in 12.10.

So my question/s is/are:
If my assumption is right - how do I get gcc 4.2.2 on Quantal?
If my assumption is wrong - what else could be the problem here?

Relevant portion of the Makefile:

# compiler options (gcc 3.4.1 will work - 4.2.2 recommended)
CPP_LIB="/usr/lib/gcc/x86_64-w64-mingw32/4.6/libstdc++.a /usr/lib/gcc/x86_64-w64-mingw32/4.6/libgcc_eh.a"

# GCC 4.2.2 optimization flags, if you're using anything below, don't use these!
OPTFLAGS=-O1 -fomit-frame-pointer -ffast-math -fforce-addr -funroll-loops -fthread-jumps -fcrossjumping -foptimize-sibling-calls -fcse-follow-jumps -fcse-skip-blocks -fgcse -fgcse-lm -fexpensive-optimizations -frerun-cse-after-loop -fcaller-saves -fpeephole2 -fschedule-insns2 -fsched-interblock -fsched-spec -fregmove -fstrict-overflow -fdelete-null-pointer-checks -freorder-blocks -freorder-functions -falign-functions -falign-jumps -falign-loops -falign-labels -ftree-vrp -ftree-pre -finline-functions -funswitch-loops -fgcse-after-reload

# put any compiler flags you want passed here
share|improve this question

Update: I just installed Hardy and installed gcc-4.2 there. The error is not happening now, so that was the problem. I'm running into others now, but I assume they are not related to the compiler.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.