Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu (12.04 x64) on my Cr-48 a few weeks ago. I'm now visiting my parents and yesterday I started having an issue with Wi-Fi connectivity for the first time.

At first I could connect to their network just fine. Then I started having this issue where I would suddenly be disconnected from the network and the only way to restore connection was to reboot. I found something online about editing the specific network connection and de-selecting the "Available to all users" option, which solved that problem temporarily. Later that night I got disconnected from their wireless network again but I haven't been able to reconnect at all since.

Their router is old as hell, the best it can do is WEP. Could that have something to do with it? My wife has had limited issues with a couple of her devices as well but nothing this severe and both of our phones are on the Wi-Fi as well as both of my parents laptops so I'd like to rule out my machine before I tell my parents to go drop a hundred bucks on a new router.

Thanks in advance, guys.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

After a full day of fiddling I finally got myself reconnected to my parents' Wi-Fi so I thought I'd put this here for anyone else in a similar situation.

My parents' router is a Liinksys WRT54G. In order to get myself reconnected I deleted the existing connection and created a new one from scratch.

  • I disabled "Connect automatically" just for schitzengiggle.
  • Listed the SSID (their's includes a space, which I thought might be a small part of the issue, turns out it doesn't matter)
  • I specifically left the "Device MAC address:" field blank. When you select a wireless network from the dropdown this field gets filled in automatically.
  • I left the MTU as automatic.

Under the Wireless Security tab:

  • Security: WEP 40/128-bit Key (Hex or ASCII)
  • Obviously enter the WEP key.
  • I left the WEP index as 1.
  • Authentication: I changed it to "Shared Key". I think maybe this is the particular thing that fixed my issue.

If things change for me I'll be back to update my question and this answer, but hopefully I'm through wrestling with this. Hope this helps someone else!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.