Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I noticed that Compiz is taking an awful lot of resources when not doing anything special. I've done some research and found that there are other people with alike problems, but I couldn't find a solution. Is there anything I can do, any upcoming patch to solve this or any alternative to Compiz?

Thanks!

share|improve this question
    
what distro are you running compiz on? is this performance degrade a recent change? what kind of specs does this machine have? quantify "taking an awful lot of resources" –  madmaze Dec 19 '12 at 19:33
    
You can file a bug report, or use a distro without compiz, for example, Kubuntu, Xubuntu, and many others. –  mikewhatever Dec 19 '12 at 19:40
    
Try to turn off some elements of the display. Since I use Xubuntu, not Ubuntu, and a localized version in German, I can't tell you the name of the setting and menu by name. 'Window finetuning' or something like this. –  user unknown Dec 19 '12 at 19:57
    
Thanks. I'm using Ubuntu OO, the machine is an Asus k52J, one year old, with 4 GB of RAM (plus 2 GB linux-swap) and a intel core with 2.Ghz, the graphic card is a Radeon 6370M MB... anything else I should take into account? "An awful lot of resources" means using almost 90 % of cpu or even more at some times. –  carllacan Dec 19 '12 at 20:15
    
How do you know it is compiz the source of the problem? –  Ed Villegas Dec 21 '12 at 1:58

2 Answers 2

I have the exact same laptop model and my cpu usage normally is about 2 - 4% usage, while running compiz. If its using that much of the cpu then yes it most definitely is using the cpu to render the compiz graphics. Sounds to me like the intel graphics aren't loading properly. If you changed some settings in your bios, try resetting them; this same thing happened to me a while ago and that is how I solved it. Other than that the laptop runs ubuntu 12.10 perfectly. Any alternative to compiz would stop any hopes of you running unity; since unity is a compiz plugin. If you do not care about that, try cinnamon, gnome-shell, kde, lxde, elementary OS pantheon, xfce, or you could try dockbarx; which supports the unity quicklists and functions very similarly to the unity dock. Try installing that x-swat drivers from the ppa or the more unstable ones.

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
share|improve this answer

Asus K52J has NVIDIA graphics and they sometimes have trouble in linux. Ubuntu 12.10 no longer comes with Unity 2D and instead relies on LLVMpipe, which is an OpenGL rasterizer that uses your CPU to render the Unity interface. This would explain the high CPU usage.

Try installing x-swat drivers to fix the problem.

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.