Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Somehow, my laptop does not associate to my wireless network anymore, while it did before. Throughout the time it stopped working, I did not perform any upgrades (kernel, nor applications).

About my system:

  • Laptop is a Dell Inspiron 1505
  • Integrated WiFi adapter based on the Broadcom BC-4311 chipset.
  • Kubuntu 12.04 with all updates in place
  • Kernel is 3.2.0-34-generic

Output from lspci:

0b:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Output from ifconfig wlan0:

wlan0     Link encap:Ethernet  HWaddr 00:19:7e:06:b4:e3  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

There is no IP assigned, but I figure that's due to the fact that I am not connected to a wireless network.

Settings -> System Settings -> Network Settings -> Wireless Tab -> Add -> Scan does show available wireless networks. I see my network (identified by its SSID) listed, I am able to select it and add it, but I am never prompted for a password as I expected it to do.

The wired LAN connection seems to work fine.

I have disabled the splash screen so I can watch the bootup process, and there didn't seem to be anything out of the ordinary going on. Except for one thing; after logging in, KWallet did not prompt me for its password, and the laptop never connects to my wireless network.

Nothing has been changed on the router, and all of my other wireless devices continue to connect without issues.

Thank you in advance for any help you can offer. If there is any additional information you require, please don't hesitate to let me know. I am relatively new to Linux and to Linux forum etiquette, so please bear with me.

share|improve this question

closed as too localized by qbi, gertvdijk, jrg Jan 16 '13 at 2:57

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
One thing you might try is to delete the wireless profile for your SSID and recreate it. So go to Kubuntu's KNetworkManager and look for the option to manage connections. Then delete the connection for your home and try to reconnect. –  Colin Matheson Dec 19 '12 at 19:59
    
Is your question still unanswered or did you find a solution so far? If you found one, it would be nice to learn about your solution or yaou can also delete your question. If you're still looking for a solution, please tell us, what you did in the meantime. –  qbi Jan 13 '13 at 13:26

1 Answer 1

A comment provided a good solution, which may well work here (or have worked here). Even if not, it would likely work for others who have this problem and find this question.

One thing you might try is to delete the wireless profile for your SSID and recreate it. So go to Kubuntu's KNetworkManager and look for the option to manage connections. Then delete the connection for your home and try to reconnect.

Colin Matheson Dec 19 '12 at 19:59

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.