Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to use the program topdrawer.
There is only a 32 bit version of topdrawer available, so according to their wiki I need to install ia32-libs to use it. However, when I try

sudo apt-get install ia32-libs

I get the following error message:

The following packages have unmet dependencies:

ia32-libs : Depends: ia32-libs-multiarch but it is not installable
E: Unable to correct problems, you have held broken packages.

I've tried to install ia32-libs-multiarch as well, but I get:

E: Package 'ia32-libs-multiarch' has no installation candidate

Please bear in mind I am quite new to linux - I only installed it a few months ago so that I could use Madgraph, which is what I now need topdrawer for.

share|improve this question
add comment

1 Answer

The app is the same with skype i think. So the workaround is to install first your app(topdrawer), better if its .deb file. It will not run after installation. You need to run sudo apt-get install -f and let apt-get automatically detect and install the dependencies. This procedure is based on installation of skype on my system that also requires ia32-libs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.