Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 on my weTab. Everything works perfectly (albeit slowly) and I can touch and use every application execpt ones written in Java.

When I start any Java Application the touchscreen does not recognize the left click.

I believe it's a problem in OnBoard (the onscreen keyboard) because when I touch the mouse icon on the OnBoard and then the Java Application the left click works.

This is very cumbersome for every click to first hit OnBoard mouse icon and then button in the Java app I would like to click. It defeats the purpose of a touchscreen.

The Java Application is definitly touchable as it's running on 10 other machines with Elo Touchscreen.

How do I get Ubuntu to recognize the left click in a java application automatically when I touch the screen? Or a way to dignose this so I can make a clear bug report?

This happens in all the desktop environments (Gnome/Unity, XFCE4 and LXDE)

I tried with openjdk-6-* and openjdk-7-*

Stats: WeTab 32GB 3G 2GB RAM Intel(R) Atom(TM) CPU N450 @ 1.66GHz - 64-bit Ubuntu 12.10 - 64 bit Unity Desktop environment Xubuntu Desktop environment Lubuntu Desktop environment The real touchscreen driver from EETI (eGalaxy) (also didn't work with the Ubuntu standard touchscreen driver)

share|improve this question

1 Answer 1

We are having the same problem with Ubuntu 12.04 on a Poindus POS device which uses eGalaxy touch driver. After trying out various possible solutions, we have come to the conclusion that the issue is with the touch driver. Hopefully they provide an updated driver through their website.

They will update drivers here: http://home.eeti.com.tw/web20/eGalaxTouchDriver/linuxDriver.htm

Edit:

Here's something that worked for us (in Ubuntu 12.04): Downgrade (by force) the xserver-xorg-core to 2:1.11.4-0ubuntu10 version. i.e. the main release without security and updates. If your version is 2:1.13.0-0ubuntu6.1 (with updates), maybe downgrading to 2:1.13.0-0ubuntu6 (main release) will do the trick? Can be easily done through Synaptic Package Manager.

Versions: https://launchpad.net/ubuntu/+source/xorg-server

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.