Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have problem with my new netbook. I installed Ubuntu 12.10 and I can't use my brightness key's (Fn+F5/F6). When i use them OSD appears and indicates the increase or decrease of brightness but nothing really happens to screen. I used this command from terminal(and it worked):

sudo setpci -s 00:02.0 F4.B=xx

But I want use my Fn keys. Is it possible to do this?

Thanks for help!

share|improve this question
Possible duplicate: – user98085 Dec 19 '12 at 12:32
up vote 7 down vote accepted

Copy-Paste from here the commands below (to your terminal) , with order and one at time


sudo sed 's/GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"/GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="/' -i /etc/default/grub


sudo update-grub

Reboot your system and see if Fn (for brightness) works.

share|improve this answer
Also fixed my problem for ASUS S551LB. – shantanu Apr 18 '14 at 7:19
Fixes the brightness buttons for ASUS G56jr too! Thank you! – Dr. Nefario Aug 2 '14 at 9:26
Worked for Asus Zenbook. Thanks! – umpirsky Sep 14 '14 at 8:57
if this doesn't work for Asus g56jr, check this: – Dr. Nefario May 29 at 19:40

protected by Community Dec 16 '14 at 21:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.