Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to use Ubuntu's online accounts feature to access my Facebook account. The thing is, my school has a proxy server you have to use to access https sites. So I configured my proxy settings accordingly. I am pretty sure the proxy setting is right because I logged into Facebook with Chrome. But when I try to log in with Ubuntu "online accounts" feature, it gives me this error.enter image description here

I am not totally sure it is a proxy problem either. I copy pasted the url into chrome and it works.

PS: The title is weird because my ISP blocks any url with the word proxy in it, and the title is incorporated into the url.

Please help!!

share|improve this question
2  
    
@fossfreedom Agree, looks like this bug. Good find! –  gertvdijk Jan 4 '13 at 22:03

1 Answer 1

Manually Edit the Configuration File

Open the file /etc/apt/apt.conf by pressing Alt+F2 and running gksu gedit /etc/apt/apt.conf. Don't worry if it is an empty file. Add these lines into the file and save it:

Acquire::ftp::proxy "ftp://Username:Your_password@domain:port-no/";
Acquire::socks::proxy "socks://Username:Your_password@domain:port-no/";
Acquire::http::proxy "http://Username:Your_password@domain:port-no/";
Acquire::https::proxy "https://Username:Your_password@domain:port-no/";

Replace username by the username assigned to you and the password by your password, domain by the domain of your proxy like 10.1.101.150, which is my college's proxy address and by the port no like 3128 or the one which you have, if you do have these parameters assigned to you, else leave out username and password and also the characters: : and @ upto domain.

To add proxy authentication parameters to other applications, have a look at this answer to a similar question.

Use the Easy GUI Utility

Another way to add this information is by going to System Settings → Network → Network Proxy then add your proxy settings and click on Apply Settings System-wide. This will add the proxy settings but you will have to add the user-name and password manually using the command-line method described above.

share|improve this answer
3  
What do the APT-proxy settings have to do with this? The OP is setting up "Online accounts". –  gertvdijk Dec 28 '12 at 13:49
    
Oh yes, I was not aware that "online accounts" need to set a proxy in some different file. I won't be able to say which file needs to be edited. Sorry for being silly. –  i08in Dec 28 '12 at 14:17
    
Ok, so I figured out that some of the applications can be configured to use proxy authentication by setting the configuration in the dconf-editor. This question may help the user to set proxy and solve the problem. –  i08in Jan 4 '13 at 9:27
2  
Can you include this in your answer, rather than posting it as a comment? –  gertvdijk Jan 4 '13 at 9:50
    
Added link to the answer I referred to. Re-posting it here would have hardly helped, as it is well explained and formatted. –  i08in Jan 4 '13 at 10:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.