Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried the steps here for a 4312:

Both of these:

sudo modprobe -r b43 ssb wl
sudo modprobe wl


FATAL: Module wl not found.
FATAL: Error running install command for wl (this one is only for the second one actually)

I tried the broadcom-sta, didn't work. What's confusing is down below in the next steps for STA with internet access it says to use the bcmwl one. So I install that and it succeeds but with some errors:

sudo apt-get install bcmwl-kernel-source

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove it.
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,181 kB of archives.
After this operation, 3,609 kB of additional disk space will be used.
Selecting previously unselected package bcmwl-kernel-source.
(Reading database ... 168005 files and directories currently installed.)
Unpacking bcmwl-kernel-source (from .../bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb) ...
Setting up bcmwl-kernel-source ( ...
Loading new bcmwl- DKMS files...
Building only for 3.5.0-21-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
ERROR: Module b43 does not exist in /proc/modules
ERROR: Module b43legacy does not exist in /proc/modules
ERROR: Module ssb does not exist in /proc/modules
ERROR: Module bcm43xx does not exist in /proc/modules
ERROR: Module brcm80211 does not exist in /proc/modules
ERROR: Module brcmfmac does not exist in /proc/modules
ERROR: Module brcmsmac does not exist in /proc/modules
ERROR: Module bcma does not exist in /proc/modules
FATAL: Module wl not found.
FATAL: Error running install command for wl
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-21-generic
jtaylor991@jtaylor991-whiteHP:~$ sudo modprobe wl
FATAL: Module wl not found.
FATAL: Error running install command for wl

Then I do the modprobe wl commands listed above and it gives the above listed errors. It didn't work with the broadcom-sta driver either. I installed the b43 ones but nothing happened, and I don't know why so those are still installed. firmware-b43legacy-installer, b43-fwcutter and firmware-b43-lpphy-installer (yes it is a LP-PHY) are currently installed.

If I go into System Settings > Software Sources > Additional Drivers it says "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary) But bcmwl-kernel-source isn't installed. I could try again but I remember rebooting and it still said this.

What's funny is it found wireless networks during the Ubuntu setup/installation, I don't remember if I got it to connect or not though. I think it kept asking for a password when I put it in (yes it was right I showed password and looked at it) so I just ignored it. But right now the Enable Wireless option in the top right is just gone, it's just Enable Networking and I'm on ethernet on this HP Pavilion dv4-1435dx right here.

If I run rfkill list it shows:

0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no

It was hard blocked at the beginning but unblocking it makes no change. Also it's a touch sensitive button, and it appears to be always orange no matter if it's enabled or not because when I touch it the hard blocked changes between yes and no in rfkill list. I think it was blue for a minute at one point.

What is going on?!?! Help me! Lol, thanks for any and all of your time guys. Oh yeah this is Ubuntu 12.10 fresh install.

share|improve this question
Possible duplicate of Installing Broadcom Wireless Drivers – Pilot6 Dec 10 '15 at 15:42

According to this page you can use the STA driver or the b43 driver for your card.

But there is a special driver for the LP-PHY version.

So I would first remove the STA driver then in a terminal type:

sudo apt-get install firmware-b43-lpphy-installer

and restart your computer.

share|improve this answer
Nope, didn't work. The other bcmwl-kernel-source is still an option under the Additional Drivers and nothing happened, "Enable Wireless" is still not an option. Yes I did restart. I uninstalled ALL of the STA stuff and restarted, then ran your command and restarted. In the following screenshot (imgur link, sorry I don't know a better way to do it) I ran the uninstall command and then opened the Additional Drivers window. You'll notice that the other option is still there after uninstalling. I did do "sudo apt-get autoremove" too while removing the STA stuff. – Jackson Taylor Dec 19 '12 at 12:40
screenshot: – Jackson Taylor Dec 19 '12 at 12:41
See if this helps. – To Do Dec 19 '12 at 13:01
Yep, it did! Thank you!!But now I have to run "sudo modprobe b43" every time I restart. It looks like b43 is still blacklisted in a couple of the .conf files (I know which ones). How do I do the opposite of "Echo" and delete a line? I tried running "nano -w /etc/modprobe.d/blacklist" and browsed to them AND replaced blacklist with each filename but I have no write access. – Jackson Taylor Dec 19 '12 at 14:05
The blacklists will be removed if you do: sudo apt-get remove --purge bcmwl-kernel-source. Reboot and see if your wireless works. If you need to modprobe b43, try: sudo su; echo b43 >> /etc/modules; exit. The wl problem is easily solvable, by the way. – chili555 Dec 19 '12 at 14:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.