Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I'm pretty new to Ubuntu but I managed to install it with no big problems on both my desktop and netbook. When I installed it on my brother's netbook everything went horribly wrong and now I fear the system is close to beyond repair.

The problem was first that it said it did not have any space left (seemed ridiculous since it had a lot). Then Ubuntu began booting into a "System is running in low graphics mode error" which I then tried to fix, using all the tips I could find in here but nothing helped. I think the graphics error and lack of space might have been related but I can't be sure.

Finally I gave up repairing Ubuntu and went for a reinstall. Shouldn't have done that! I read that I should simply open Ubuntu through a live usb and choose GParted to delete the Linux partitions so I did and rebooted accordingly. Next, I was to install Ubuntu but now I am only given the option to wipe the whole disk for Ubuntu, not install along with windows 7.

If I access GParted I can still see the ntfs partitions that hold windows 7 (there are 2: one labeled RECOVERY and another labeled OS and boot) so why can't I access them? Btw. the OS and boot has a little red mark with a warning that 1 cluster is referenced to multiple times, don't know what that means. If I boot without the live usb I am sent directly into a grub rescue "black screen of the computer will follow no orders". Please, I know that the easiest might be to simply wipe the whole thing clean but there are important files and programs on windows 7.

Is there a way to just access windows? It is a dell inspiron 1018 mini netbook, so I have no cd input and no windows 7 installation cd.

share|improve this question
add comment

2 Answers 2

If I understand correctly, you started with by installing Ubuntu alongside windows, resizing the existing NTFS partition in the process. Subsequently you deleted the Ubuntu partition created by this install leaving a large block of unallocated space? (If this is wrong, a screenshot of gparted showing the disk layout would be useful.)

If you haven't done anything further to the windows partition, the contents should hopefully be intact. The red mark probably reflects the fact the windows filesystem checker needs to be run after resizing, which should happen the next time windows is booted.

I would try starting with the live USB and using gparted to manually create an ext4 partition in the empty space, and then try running the installer again. That should at least get you working grub and hopefully be able to boot into windows again, providing the NTFS partition is intact.

share|improve this answer
    
You understand it correctly and no I have not touched the windows partitions. I tried your way but nothing has happened. How could it even install ubuntu on 4 gb in the first place? –  First timer Dec 19 '12 at 19:41
add comment

You can solve your problem by using the "Something else" option of the Ubuntu installer.

Create two partitions in the empty space left by the deleted partitions:

Partition 1: Fill up all the empty space, leaving just 4 Gb for Partition 2. Mount point: / Partition 2: size 4Gb. Type: Swap.

Go ahead with the installer.

That's it!

share|improve this answer
    
When I installed Ubuntu, it seems to only have installed from 4 GB totally. Do you think I can do with that or? –  First timer Dec 19 '12 at 19:17
    
4Gb for all of Ubuntu? It the bare minimum but it's not enough. You need at least 20Gb in my opinion. –  To Do Dec 19 '12 at 21:36
    
I know, but the installer then said it used 10 gB. It's so weird. Now I hardly dare shrink the windows partitions for fear that will make the computer explode or something ... –  First timer Dec 20 '12 at 16:23
    
Try shrinking the Windows partition from Windows using its partition editor. –  To Do Dec 20 '12 at 16:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.