Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

2 weeks ago, I installed Ubuntu 12.10 on my PC. Everything is fine except from my wireless usb adapter. I have a ISY WLAN USB-Adapter IWL 1000 N150. I tried several ways to make it work but nothing. Probably i need a firmware - driver because it is not recognized from the operating system. Does anyone know how can i install drivers for this network adapter? This is the first time working with Ubuntu for me, so I need a little bit of help. Thanks.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

sorry, I've made a misstake, it must be

sudo modprobe r8712u

This is the appropiate kernel module.

I've also opened the ISY IWL 1000 adapter and a Belkin N150 F7D1101 v1 and it's exactly the same hardware.

share|improve this answer
    
So is this the correct modprobe for this device? We should fix the first answer instead! –  Jorge Castro Dec 25 '12 at 14:30
    
Great news!!! It works. Thank you very much. The usb adapter is recognized but now it keeps asking me the password for the router. Do you have any idea? –  kostas lazaridis Dec 25 '12 at 20:33

I've managed to get this stick working, but driver quality seems to be poor, I got some disconnects here. To me it looks like the IWL 1000 is in fact a Belkin Components F7D1101 v1 Basic Wireless Adapter [Realtek RTL8188SU]. This device is supported by the r8712u kernel module. But the ISY IWL has a different device ID so the driver doesn't get loaded automatically. So you could assign the new ID to the kernel module:

echo 'install r8712u /sbin/modprobe --ignore-install r8712u; /bin/echo "050d 11f1" > /sys/bus/usb/drivers/r8712u/new_id' | sudo tee /etc/modprobe.d/r8712u.conf

after that see if it was successful:

sudo modprobe r8712u
iwconfig
dmesg | egrep 'rtl|wlan|Firm'

You should get something like this:

[ 2392.062628] r8712u: register rtl8712_netdev_ops to netdev_ops
[ 2392.797877] r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[ 2393.127647] udevd[2991]: renamed network interface wlan1 to wlan2
share|improve this answer
    
Hello, I tried your solution and I got "usbcore: registered new interface driver rtl8192cu" but again the adapter didn't work. The lsusb give me 050d:11f1 Belkin Components as a result. According to link I have 11f2 ISY Wireless Micro Adapter IWL 2000 [RTL8188CUS]. I also tried to install the official drivers from Realteck but nothing again. –  kostas lazaridis Dec 24 '12 at 19:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.