Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu both as guest and as host. I use VirtualBox 4, just downloaded from the official repository. After installing the guest extensions, I got this strange problem:

When I activate the resizable screen mode with Host + C, the GNOME desktop won't resize with the screen. Only the wallpaper gets stretched. I use no desktop effects and haven't changed any driver options yet.

Any ideas how to fix this? Here is a screenshot of the guest machine, demonstrating how it looks like after changing the resolution:

enter image description here

I know how to use scalable mode, but I guess I forgot some configuration in the guest machine to make it work.

share|improve this question

1 Answer 1

Virtual Box Scaled Mode (Host+C)

Virtual Box has the option to run in "scaled" mode. This means that any screen size will be enlarged or reduced by the same factor as the host windows size changes. The scaling also effects desktop elemets that may be rendered distorted then:

VBox scaled

Virtual Box Non-Scaled Mode (Host+A)

When Guest Additions are installed (see this answer), and only then, we are also able to fit the guest desktop to an altered host windows size. Desktop elements will then be rendered correctly to fit into the virtual desktop size.

VBox non-scaled

Pressing the key commands switches the given feature on or off.

share|improve this answer
    
I know this feature. I enabled it. My question was actually, that the gnome-desktop won't scale with the screen, only the wallpaper get's extended. I guess I have to correct some driver options. –  FUZxxl Jan 25 '11 at 11:37
    
I have a Thinkpad R500 with intel chipset graphic. I guess it's a problem with the guests configuration. –  FUZxxl Jan 25 '11 at 12:54
    
It seems to work with [Host]+A, but not in the mode with [Host]+C. Can you put this information in another answer, so that it's clearly visible that this is what I accept as an answer (or edit yours). –  FUZxxl Jan 25 '11 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.