Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.10 (Verified the ISO hash as well). The VERY first thing I did was open the software centre and try to install banshee. I am met with the following error:

The following packages have unmet dependencies:

     banshee: Depends: libc6 (>= 2.7) but 2.15-0ubuntu20 is to be installed
     Depends: libglib2.0-0 (>= 2.34.1) but 2.34.0-1ubuntu1 is to be installed
     Depends: libgtk2.0-0 (>= 2.24.0) but 2.24.13-0ubuntu2 is to be installed
     Depends: libsoup-gnome2.4-1 (>= 2.27.4) but 2.40.0-0ubuntu1 is to be installed
     Depends: libsoup2.4-1 (>= 2.26.1) but 2.40.0-0ubuntu1 is to be installed
     Depends: libx11-6 (>= 2:1.4.99.1) but 2:1.5.0-1 is to be installed
     Depends: mono-runtime (>= 2.10.1) but 2.10.8.1-5ubuntu1 is to be installed
     Depends: libc0.1 (>= 2.15) but it is not going to be installed
     Depends: libgconf2.0-cil (>= 2.24.0) but 2.24.2-2 is to be installed
     Depends: libgdk-pixbuf2.0-0 (>= 2.26.4) but 2.26.4-0ubuntu1 is to be installed
     Depends: libglib2.0-cil (>= 2.12.10-1ubuntu1) but 2.12.10-4 is to be installed
     Depends: libgtk2.0-cil (>= 2.12.10-1ubuntu1) but 2.12.10-4 is to be installed
     Depends: libmono-cairo4.0-cil (>= 2.10.1) but 2.10.8.1-5ubuntu1 is to be installed
     Depends: libmono-corlib4.0-cil (>= 2.10.1) but 2.10.8.1-5ubuntu1 is to be installed
     Depends: libmono-posix4.0-cil (>= 2.10.1) but 2.10.8.1-5ubuntu1 is to be installed
     Depends: libmono-system-core4.0-cil (>= 2.10.3) but 2.10.8.1-5ubuntu1 is to be installed
     Depends: libmono-system4.0-cil (>= 2.10.7) but 2.10.8.1-5ubuntu1 is to be installed
     Depends: gnome-icon-theme (>= 2.16) but 3.6.0-0ubuntu2 is to be installed

I should note that the banshee application appears three times when searching for it: http://i.imgur.com/fJOsb.png

Other applications install fine though.

I installed the latest updates and still received the same error. I even tried reinstalling Ubuntu, but the same thing happened.

share|improve this question
2  
It appears to be bugged, see launchpad.net/bugs/1091942. –  psusi Dec 19 '12 at 4:21
1  
It was working for me a week ago, but I had to reinstall Ubuntu due to an unrelated problem. That's when this happened. –  Ben Cracknell Dec 19 '12 at 4:24
1  
It doesn't look that way... it hasn't been changed since release so it wouldn't have been installable last week either, unless you weren't running 12.10 then. –  psusi Dec 19 '12 at 4:38
add comment

1 Answer 1

Banshee is uninstallable due to broken depends. This is because the PPA for Banshee Team has NOT allowed or created a repository for 12.10 yet check this https://launchpad.net/~banshee-team/+archive/ppa and you will see what I mean.

you can try adding it using sudo apt-get install banshee

For those who wish to compile from trunk, add the deb-src line and then run "sudo apt-get build-dep" to install all required dependencies before starting to compile.

see https://launchpad.net/~banshee-team/+archive/ppa for reference

share|improve this answer
    
It definitely worked for me previously on 12.10 (about a week ago) but after a reinstall, this happened. –  Ben Cracknell Dec 19 '12 at 4:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.