Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Equipment: Pre-loaded Windows 8 Laptop, needs multi-boot capability (Win8 + Linux and BSD) Lots of USB 3.0 sticks and blank DVD-Rs. Various ISO's, including Ubuntu Secure-remix 12.10

Problem: After burning aforementioned Ubuntu iso to DVD (or USB), the live disc does not boot in EFI mode. Booting into Legacy mode installs for legacy mode. This makes Windows not work without switching back and forth.

Requirements: A pre-loaded windows 8 machine that can boot a liveDVD in EFI mode, install Ubuntu 12.10 64-bit in EFI mode, and finish with a multi-boot capable machine.

What is done already: ISO's downloaded. Partition shrunk, leaving lots of room to play with, Ubuntu installed in legacy mode. Windows and Ubuntu work but have to switch EFI depending upon which is being used.

What isn't done: Anything with GRUB.

share|improve this question
    
Does your machine have secure boot enabled? If so, you'll need to disable it until to boot Ubuntu in EFI mode (until Ubuntu 13.04 is released). –  Xiao-Long Chen Dec 19 '12 at 5:36
add comment

2 Answers

I think that I have the same basic issue, the Ubuntu 12.10 Live DVD doesn't boot into EFI mode so the installer is not installing Ubuntu in EFI mode even if the hard drive is partitioned as a GPT drive. So when the install is finished, no boot loader works because Windows 8 is in EFI mode and Ubuntu isn't.

If I select EFI only, in the system setup the DVD drive doesn't boot at all.

I'm not sure if there is any possible solution.

Someone stated that Secure Boot support is not coming until 13.04, but I thought that it was already in 12.10. Turning on Secure Boot might force the DVD drive to operate in EFI mode. But who knows?

I tried installing "rEFInd" in Windows 8 and got as far as step 10 at http://www.rodsbooks.com/refind/installing.html#windows but as Rod stated, he hasn't tested that step and the install fails at that step.

So the bottom line is to get a second hard drive and install Ubuntu on it and switch between the drives.

I find that if I set the system setup to EFI only then Windows 8 boots and if I set it to Legacy only then Ubuntu boots, but Ubuntu can't mount the Windows volume so no file sharing between OSes (stick in a USB stick to do this).

share|improve this answer
add comment

It sounds like you've already installed Ubuntu in BIOS mode. If I'm mistaken, you can either do so or try my first suggestion and/or a rEFInd installation to boot the installer in EFI mode to do the installation directly in that way.

First, try disabling Secure Boot and booting the Ubuntu installer in EFI mode. Secure Boot support is brand-new in Ubuntu 12.10, and it may yet be buggy, so eliminating Secure Boot as a possible troublemaker is worth trying.

If that works, you can boot the Ubuntu disc into live CD mode and use it to install the EFI boot loader of your choice. Ubuntu 12.10 uses GRUB 2, but several others are available, and you may prefer one of them. You could try something similar with the System Rescue CD, which supports an EFI-mode boot.

If you can't seem to get Ubuntu or System Rescue CD booted in this way, try installing my rEFInd boot manager from within Windows. (You'll need to either disable Secure Boot or jump through some extra hoops to get it working, though.) A basic installation with no extra changes will present a menu with Windows and nothing else; but you can enable a boot to Ubuntu in either of two ways:

  • You can edit the refind.conf file, uncomment the scanfor line, and add hdbios to the list of options. This will enable scanning for, and booting to, BIOS-based OSes, such as your Ubuntu installation. This option works with many, but not all, UEFI-based PCs.
  • You can install the ext4fs driver that comes with rEFInd 0.6.0. This will enable rEFInd to search for Linux kernels and launch them from your regular installation. You'll also need to create a refind_linux.conf file and put it in your Linux /boot directory, though; without it, the kernel will launch but it won't be able to find your root filesystem. You could do a one-time boot by selecting the Linux icon, hitting the Insert key a couple of times to bring up the editor, and adding ro root=/dev/sda3 (or whatever the Linux root partition's identifier is) to the boot options. Once Linux is up, running the mkrlconf.sh script that comes with rEFInd should generate a suitable configuration file to obviate the need for manually entering this option.

The last I heard, none of the BSDs had a working EFI-mode boot loader. If I'm misinformed or if this has changed recently, you should be able to install BSD and select it with rEFInd. If the BSDs are still behind the EFI times, though, you'll need to use either your firmware's selection tool or rEFInd to switch between Windows and BSD; AFAIK, no other boot program can switch BIOS/EFI boot modes on UEFI-based PCs. (rEFIt can do this on Macs, though.)

share|improve this answer
    
Yes, because I could not get the DVD to boot in EFI mode, I had to switch to legacy mode which resulted in a BIOS type install. I have found information on how to convert it into a EFI type install at help.ubuntu.com/community/UEFI, using boot repair but have been hoping to avoid that for fear of problems with windows after. Since Enter keeps saving instead of creating a new line I will continue, sorry for the run on in advance. Secure Boot was disabled before I started to prevent issues from it. I am going to try to Boot Repair now, if that fails I will try rEFInd. –  Ben Nesbitt Dec 20 '12 at 4:17
    
Correction to above: I could not get the DVD to boot in EFI mode, I had to switch to legacy mode which resulted in a BIOS type install. I have instructions to switch a bios install the a efi install but avoiding that would be preferable. That is the issue here, they are MBR not EFI. Thank you for the idea of rEFInd, it is taken with gratitude but the problem is the LiveDVDs not booting into EFI mode to begin with where the problem lies. –  Ben Nesbitt Dec 20 '12 at 4:27
    
I think you're misunderstanding something. MBR and GPT are both partition table types. BIOS and EFI are both firmware types. Thus, "...they are MBR not EFI..." is crossing two distinct classes that aren't directly comparable, although they are somewhat linked: Windows boots in BIOS mode only from MBR disks and in EFI mode only from GPT disks. If Windows is still booting, it's probably doing so in EFI mode, and using GPT. The easiest way to get Linux to co-exist with this is to convert it to boot in EFI mode, too. Sticking with BIOS mode for Linux makes little sense. –  Rod Smith Dec 20 '12 at 5:06
    
But that is not the point of the question. What is needed is a LiveDVD that can boot in EFI mode. I do not want to have to switch to legacy mode to use a Live DVD every time. Ergo I asked, "How to make a Live DVD EFI bootable?" –  Ben Nesbitt Dec 20 '12 at 21:51
1  
By default, rEFInd shows EFI-bootable external media it discovers, but the media must already be EFI-bootable. You can add the cd option to the scanfor option in refind.conf to have rEFInd scan for BIOS-bootable optical discs. –  Rod Smith Dec 22 '12 at 2:29
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.