Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Following the tutorial in https://help.ubuntu.com/community/UEC/Images#DownloadUECImages I was able to execute the Ubuntu 12.04 Cloud Image (amd64) in my computer (http://cloud-images.ubuntu.com/precise/current/precise-server-cloudimg-amd64-disk1.img), so I can add whatever I want before uploading it to my Openstack Cloud. However, when I log in I receive a message saying that my environment specifies an invalid locale. In order to sort this out, I run locale-gen, obtaining the following:

ubuntu@ovfdemo:~$ sudo locale-gen 
sudo: unable to resolve host ovfdemo
Generating locales...
  en_US.UTF-8... /usr/sbin/locale-gen: line 243:  1435 Killed                  localedef $no_archive -i $input -c -f $charset $locale_alias $locale
failed
Generation complete.

ubuntu@ovfdemo:~$ locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
C.UTF-8
POSIX

ubuntu@ovfdemo:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

This does not happen in the i386 version of the same image (http://cloud-images.ubuntu.com/precise/current/precise-server-cloudimg-i386-disk1.img). What can I do to solve this problem?

share|improve this question
add comment

1 Answer

I managed to solve the problem. It was because the RAM memory I used to boot the image was not enough. I used the qemu -m flag and used a value such as 256 and it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.