Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have added my mount devices in /etc/fstab and they get correctly mounted (2nd partition with ntfs and nas-share with nfs).

I have also disabled automount in Nautilus preferences by using dconf-editor (following this post):

user@server:~$ gsettings list-recursively org.gnome.desktop.media-handling

org.gnome.desktop.media-handling automount false
org.gnome.desktop.media-handling automount-open false
org.gnome.desktop.media-handling autorun-never false

Now i see every mount device twice in Nautilus (the entry in fstab already mounted). When clicking on the other entry i get the eligible message

mount.nfs: /media/nas_share is busy or already mounted

How i can i disable the appearente of those devices in Nautilus?

EDIT Regarding automount:

I have only one line in /etc/auto.master:

+auto.master
share|improve this question

1 Answer 1

I suggest you abandon the /media... mount point and make some directories under /mnt. Use noauto in the fstab for any /mnt entries you do not want automounted. Seems that the noauto option is ignored when present on any /media mount point by whatever desktop software thinks it has to mount everything it sees.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.