Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I often use gcalctool, to quickly convert a number between "binary/hex/decimal". For this I find the "Programming" mode of gcalctool useful. I can select this using "Mode → Programming" from the toolbar.

However, this gcalctool setting does not appear to be preserved between restarting gcalctool. Is there a way I can force this? E.g entering something in ~/.gcalctoolrc

share|improve this question
add comment

2 Answers

This was a bug in Ubuntu 10.10 but as you can see from the bug report, it should have been fixed with version 5.31.4-0ubuntu4.

What version are you using (in a gnome-terminal, run apt-cache policy gcalctool)?

Have you tried reinstalling it (run sudo apt-get install --reinstall gcalctool)?

share|improve this answer
    
I am using version 5.32.0-0ubuntu4 (thanks for the command). I tried reinstalling, but this did not fix it for me. –  Jon Brett Jan 26 '11 at 8:46
    
This works on my home computer (regular single-user Ubuntu 10.10 install), but not on my work computer (my user is a NIS user, and I have local root access). I think it is to do with my NIS user not having access to files created by the local root account, during an apt-get install, since these files were created with umask 007. I will try and find-out what these files are and change the permissions. –  Jon Brett Feb 18 '11 at 8:27
add comment

I had the same problem, and have gcalctool version 5.32.

I gave up and installed qcalculate instead which can do binary/hex/decimal conversions.

More a workaround than a solution I'm afraid.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.