Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been able to get the built-in microphone (it's an Acer laptop) to not only work, but work perfectly in Ubuntu's own Sound Recorder, but when starting up Skype, there's no sign of my microphone at all.

I've reinstalled Skype, checked ALSAmixer and tried various settings.

share|improve this question
The sound settings for Skype are IN Skype and NOT in the computer sound settings. Skype>S Button (bottom left)>Options>Sound Devices. You need to experiment with the various settings available to find the right one... – arochester Jan 24 '11 at 14:04
Have you set the microphone to pulseaudio server on your Skype audio options ? If other pulseaudio enabled apps can work with your mic skype should also be able to do it. – João Pinto Jan 24 '11 at 15:17
Hi - pulseaudio is the only option that's available inside skype – Industrial Jan 25 '11 at 20:38
Yes, this is realy strange, but as glenatron said... On acer aspire one netbook you have to unbalance left/right channel for microphone.. greater difference greater input volume.. :/ weird – user24210 Aug 31 '11 at 20:55
Im Having the exact same problem on Acer Aspire, Ubuntu 12.04 – Fawkes5 Jun 30 '12 at 19:35

10 Answers 10

up vote 6 down vote accepted

I've had weird problems where the mic was muted and I had to use pavucontrol to unmute it. You can install the additional pulseaudio utilities:

sudo apt-get install paman padevchooser paprefs pavucontrol pavumeter

Check the input tab in pavucontrol and make sure its not muting your mic. You can also play with the configuration tab in case that is wrong, but note your initial setting first.

Keep in mind what arochester and Joao are saying, make sure pulseaudio is selected in the skype audio options.

share|improve this answer
Hi Djeikyb! Thanks for your advice. I did this and actually noticed that the microphone were really low and try to boost it in many ways, but failed :( – Industrial Jan 25 '11 at 20:22

I have an Acer Aspire netbook and had exactly the same problem - microphone worked for recording, would not work with Skype, only PulseAudio input available on Skype so I couldn't manually provide the microphone name.

Absolutely weirdly what worked for me was to go to my PulseAudio volume control for the input on the microphone and make sure my left and right channels were not at the same level. I have no idea why, but turning down either channel made the microphone work well enough for skype...

share|improve this answer
I have the acer aspire one and after weeks of trying to make it working, it finally works! I once even removed the whole PulseAudio and installed ALSA to have the mic working. You need to install pavucontrol to change mic balance. – crenate Jul 5 '12 at 9:15

by these steps :-

  1. Run alsamixer
  2. Unmute all the outputs by hitting “m”
  3. Hit tab to go the capture settings
  4. Highlight the “Mic” setting using the arrow keys.
  5. Hit space to enable the microphone.
  6. Highlight the “Capture” setting using the arrow keys.
  7. Hit space to enable capture (note that just because you have volume bar here doesn’t mean it is enabled).
  8. Hit escape.
share|improve this answer
How do you see what is enabled and what is not? – Benjamin Aug 27 '12 at 6:16

I just unchecked "Allow Skype to automatically adjust my mixer levels" and mic is working now

share|improve this answer
I find I have to do this on nearly every fresh Ubuntu install, and it always works for me. Some additional fiddling in Sound Preferences' Input tab to get the correct input device and audio level may also be needed. – Christopher Kyle Horton Sep 1 '11 at 1:23

I had the same problem on my Lenovo E325.

This is what solved the problem for me:

  1. in Terminal type alsamixer
  2. With F6 you can change between audio devices, with F4 you are changing the Capture settings - make sure, that Capture device is not muted (a good indicator is if you can change with up and down arrow the amount of bars for the CAPTURE)
  3. Assuming you have PulseAudio installed, Go to Options/Sound Devices in Skype
  4. Click "Open pulse Audio Volume Control"
  5. While in Volume Control Settings, make a test phone call (you may use skype Echo or call your friend, you need a way to check if the method is working)
  6. While making the call, you can see in "Recording" Tab of Volume Control different devices you can choose from - try to change between them and see if person on the other sound of the line is hearing anything.

I think the cause of this problem is that if you have many Audio sources (e.g. Audio In Jack for external Microphone and Built in Microphone, like in my case) you have to let Skype know which one it should use. When I changed it in Recording Tab it resolved my issue. Good luck!

share|improve this answer

I had issues on some laptops where Skype would not use the internal microphone, but rather use the microphone input jack. Check the options dialog in Skype if there are multiple microphone choices and try different ones.

share|improve this answer
Hi Peter. That's strange. Will try it asap when I have a mic around and get bcack to you! – Industrial Jan 25 '11 at 20:24

I had the same issue with my Samsung N150 Plus netbook using 11.04. I found that my sound preference settings had changed after a reboot or update.

On my system the internal or external mic's do not register at all in the 'Input' tab of 'Sound Preferences' unless the profile setting in the 'hardware' tab are changed from 'analog stereo output' to 'analog stereo duplex'. Once the profile is set to duplex, I can see the internal mic and any external mic's I plug in on the 'input' tab and it works fine assuming nothing is muted and volumes are correctly set.

share|improve this answer

The following instructions for installing the latest ALSA packages via the DKMS .deb installer worked for me on the Acer 5520.

Oneiric 11.10

share|improve this answer
While providing links is useful, it would be MORE helpful to the asker if you posted a summary of the steps involved on the link you posted. – user323419 Oct 1 '15 at 16:20

Just would like to confirm what glenatron said. I have acer aspire netbook and with the same issue with skype on ubuntu. I tried putting the right and left mic channels at different levels as glenatron said but they would always move together. This was solved when I clicked on the padlock icon which locks/unlocks the channels together. I was then able to slide one channel independently of the other and the mic now works with skype. Exlpanation? Not sure but it seems since my acer netbook has only one mic input point, putting the too channels on the puvacontrol at same level may have created some conflict or sent inaccurate signal.

share|improve this answer

If lsusb shows your USB device is present, make the USB microphone the preferred device in system settings.

System Settings > Multimedia > Phonon > Audio Recording > Recording > Prefer (until the USB device is listed first)

That worked for me and Skype.

share|improve this answer
In the question it's stated that the microphone is built in and not inserted via a USB. so why would it show up in lsusb? – Alvar Aug 15 '13 at 13:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.