Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have mounted a couple of network shares with my etc/fstab file - it works great, just like it's supposed to, but unfortunately every mounted drive keeps appearing twice!

When clicking one of the duplicates, an error is shown; Unable to mount: [mountname]. Mount: According to mtab, [mount address], is already mounted on [local mountpoint]. Mount failed.

Here's how each mountpoint looks in my etc/fstab:

//192.168.1.2/backups /media/backups cifs defaults,user=myUserName,pass=myPassWord,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

What can I do to make sure that my mounted drives only are listed once?

share|improve this question
    
I am getting all crazy about this - bounty is ON! –  Industrial Jan 28 '11 at 11:31
add comment

3 Answers

up vote 7 down vote accepted
+50

This is a know bug and I could not find a proper solution. Apparently the bug might be triggered by custom options on the fstab line.

See https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/442130 and https://bugzilla.gnome.org/show_bug.cgi?id=597420

share|improve this answer
add comment

Follow these steps:

  1. Download ccsm
  2. open ccsm
  3. Desktop
  4. Ubuntu Unity Plugin
  5. Experimental
  6. Show Device : select Never
share|improve this answer
1  
Welcome to Ask Ubuntu. I'm not sure if you are trying to be sarcastic or not but that is not a solution for the problem. –  Octavian Damiean Dec 13 '11 at 23:16
add comment

(Further to what @user4124 said and their links) In you FSTAB lines make sure you do not use the user option as this is one of the triggers for the double-up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.