Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I'm having some trouble with getting my Ubuntu to work on a VirtualBox VM. I made a clean installation of Ubuntu 12.10 on a VM without any errors. I arrive at the login screen, as soon as I press enter it does it's little loading thingy and then screen goes black, then this is all I get:

I can access the terminal and pretty much all the other features through it, but I would like to have the GUI properly working. I've been looking around the web and looking at various fixes to similar problems, but can't seem to get it to work. I'm thinking this problem might have to do with the graphics?

I'm running Windows 8 Pro as host, if that helps, might be some compatibility issues with VirtualBox in W8...

Thanks in advance!

share|improve this question

marked as duplicate by Eliah Kagan, Luis Alvarado Aug 4 '14 at 19:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

See… – user68186 Dec 18 '12 at 17:36
Did you install the Guest Additions? – Takkat Dec 18 '12 at 18:56
I tried that, but made no difference, can try it again :) – Jake Dec 18 '12 at 18:58
up vote 4 down vote accepted

Accepted Answer

You could alternatively install gnome classic in order to get a functional desktop:

sudo apt-get install gnome-session-fallback

Reboot the pc and select "Gnome Classic (No Effects)" from the session list.

Original Answer

open a terminal and type

sudo apt-get install compizconfig-settings-manager

after installing type: ccsm

hopefully a window will open. tick "Unity".

share|improve this answer
Under which category? The closest I can find is the "Ubuntu Unity Plugin", but is already activated, and is under the "Desktop" category... – Jake Dec 18 '12 at 18:24
When I said open a terminal, I meant press Ctrl+Alt+T. Then type the two commands above.... – Dialogos Dec 18 '12 at 18:26
Sorry, forgot to mention that I had done that. When i open ccsm, there is no option called just "Unity" :/ – Jake Dec 18 '12 at 18:33
Weird... last time I checked it had for me.. anyway, you could type sudo apt-get install --reinstall unity and/or sudo apt-get install --reinstall ubuntu-desktop. Hope that helps! – Dialogos Dec 18 '12 at 18:40
I really appreciate the help! Will get back to you once I've done what you've told me! – Jake Dec 18 '12 at 18:43

I wrestled with this one for a couple of days before a friend told me that I needed to enable Virtualization on my CPU in my BIOS. That fixed it!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.