Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two Ubuntu 12.04 systems, one a desktop, and the other running as a NIS/NFS server (a desktop with lightdm disabled). When I login, I get the dialog (not error) "Authentication is required to change user data" The Details section of the dialog says "org.freedesktop.accounts.user-administration"

Any help helping me figure out how to make this dialog go away is appreciated.

BTW, not entering the password has no effect whatsoever.

share|improve this question
    
Could you solve this problem? I have the same issue on a range of machines authenticating via Active Directory (centrify). –  uzhoasit Jun 5 '13 at 17:49
    
@uzhoasit: Sorry, no luck yet. I am not sure what the problem is, still. –  Sonny Jun 5 '13 at 18:03
    
Seems to be an issue with Unity. I try to fix it with support from Canonical. I'll post back the results. –  uzhoasit Jun 10 '13 at 5:25
    
How do you authenticate your users? Normal local users with local passwords? –  uzhoasit Jun 13 '13 at 15:41
add comment

2 Answers 2

up vote 1 down vote accepted

You need to set the usernames (local:bob, network:bob) to have the same UID. You would likely want to change the local account as opposed to the network one.

In my setup: I ran id bob to get the AD/network UID. Then I edited /etc/passwd and changed the UID of the local bob account. (This can be dangerous, if you mess up!)

If you have a graphical environment go to Users and Groups -> Click on the user account in question, Advanced Settings, and then change the UID there.

The indicator-applet issue will not be fixed in Ubuntu (even though it is caused by an Ubuntu specific patch): You can see more details here: https://bugs.launchpad.net/ubuntu/+source/indicator-messages/+bug/1192300

share|improve this answer
add comment

Seems to be an issue with messaging indicator.

As an intermediate solution you can remove the messaging indicator with sudo apt-get remove indicator-messages

share|improve this answer
    
Though this was the solution I adopted, the reply due to gQuigs below gave me a better picture of why. I hope you don't mind me selecting the answer due to gQuigs. –  Sonny Jul 8 '13 at 22:06
    
@Sonny: The solution from qQuigs is the official one. So its ok to select it as solution. –  uzhoasit Jul 9 '13 at 0:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.