Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.10. On the log-in screen, there is no Ubuntu icon for me to click on to change desktop environments. I know where it should be, but it is simply not there. Why is this? And how can I get it back??? I just installed Cinnamon and I would very much like to switch to this environment.

I apologize if this is has been addressed elsewhere, but I honestly did try to research before asking. I found several similar questions, but nothing that has answers that helped my situation. And an hour of Googling did not produce anything helpful at all.

Thank you for your help.

share|improve this question

2 Answers 2

I think you somehow uninstalled ubuntu-desktop. Try to reinstall ubuntu-desktop by typing:
sudo apt-get install ubuntu-desktop into a terminal.

share|improve this answer
    
OP doesn't want to install the regular Ubuntu Desktop for this, Cinnamon is installed. –  gertvdijk Dec 20 '12 at 0:01
    
I went ahead and tried it to see if it would help any, but no change. I appreciate it, though. –  dtdlurch Dec 20 '12 at 0:07
up vote 1 down vote accepted

SOLVED IT:

After much digging and asking for help, a gentlemen passed on a link (below) that had the following information:

The session switcher will only show up if you have more than one VALID session; a valid session is one that points to a valid executable. By default in 12.10 you will have a session file for gnome-shell, but gnome-shell won’t be installed, so the session is invalid, leaving you with a single valid session (Ubuntu), and hence no session selector!

I was very confused because, I know I had already run the Cinnamon install. But, this at least gave me a reason for the icon not to be there. So, I figured I would run the Cinnamon install again, despite having already run it twice. This time around, it began downloading even more files. I reset the computer and , surprise, the icon was there! It even had the GNOME options available too, despite the fact that the link suggested it wasn't installed...

So, I'm not sure exactly what happened. I can only assume that, while I was working on getting several drivers to run properly after the initial install, I must have messed something up.

Thanks for the help, everyone.

https://wiki.ubuntu.com/LightDM#Change_the_Default_Session

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.