Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time, when i hit k button in a terminal window in vim, so it happens fairly often, it invokes the Find pop-up. I could not find where this can be turned off.

I do not have this problem at home where I also run 10.10.

share|improve this question
    
i did find in the edit/keyboard shortcuts the "enable the menu shortcut keys" which i unchecked but nothing changed, the search still appears every time I press k. –  Ashnur Jan 24 '11 at 12:29

2 Answers 2

up vote 0 down vote accepted

I had similar problem for days. When I pressed "B" key while writing commands in terminal, set title dialog appears. It was so boring.

Finally I realized the problem. It's because of "Editable Menu Accelerators". I hovered the related menu item (in this case Set Title) and changed the shortcut from "B" to another combination. Backspace removing the sortcut.

For more: http://docs.xfce.org/faq#editable_menu_accelerators

share|improve this answer

That should be either a function of the window manager or the terminal emulator. You didn't say which terminal emulator you are using, but most have menus to handle keyboard shortcuts.

For the window manager, click on the Xfce icon on your panel (has the X with the mouse), then go to Settings > Keyboard and click on the "Application Shortcuts". You can remove the shortcut with the "- Remove" button.

If you do not see the entry listed there, then it is likely the function of the terminal emulator. Let us know which emulator you are using and we can give more info for you.

share|improve this answer
    
in the about/help says that it's gnome-terminal 2.32.0, dunno why, I had ubuntu, then I installed xfce. seems that it did not changed the terminal. anyway, I know that this terminal emulator has a Search menu wich indeed has the shortcut key set. my problem is - as i mentioned in the previous comment - that I want to disable this using the ed/keyboard shortcuts menu item from the terminal where it says "enable the menu shortcut keys" (F10) but it does not matter if this is checked or unchecked, the K shortcut remains enabled. –  Ashnur Jan 24 '11 at 18:33
    
Yes, for xfce, you need to install xfce4-terminal from the repositories (sudo apt-get install xfce4-terminal). I cannot find anything on gnome-terminal that sets 'k'. I'm still running 10.4 with gnome-terminal 2.30.2, which does not have search/find functionality. That leads back to the window manager; you might want to try xfce4-keyboard-settings and xmodmap -pk, which you want to run within the term emulator. xmodmap will show you all possible keyboard translations; look for "(k)" and see if it is sending a different keycode. –  Arcege Jan 26 '11 at 1:41
    
since I switched to Arch linux with nwm, all these crazy problems just went away. I use sakura and/or lilyterm now, both work as charm. –  Ashnur May 28 '12 at 17:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.