Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In order to use kghostview, I download the page from here. After that, I run the following command:

sudo dpkg -i kghostview_3.5.10-0ubuntu1~hardy1.1_i386.deb

However, I have the following error messages:

dpkg: dependency problems prevent configuration of kghostview:
 kghostview depends on gs; however:
  Package gs is not installed.
 kghostview depends on kdelibs4c2a (>= 4:3.5.8-1); however:
  Package kdelibs4c2a is not installed.
 kghostview depends on libqt3-mt (>= 3:3.3.8-b); however:
  Package libqt3-mt is not installed.
dpkg: error processing kghostview (--install):
 dependency problems - leaving unconfigured

It seems that I should also install some external packages such as gs, kdelibs4c2a and libqt3-mt. However, I do not have any idea of how to install them. I try the sudo apt-get install command, but fail. Any idea will be appreciated.

share|improve this question
The package appears to be for Ubuntu Hardy (8.04). Unless you are running that version, or something near, the package will be expecting the wrong version of most of the system libraries and consequently not work. – chronitis Dec 18 '12 at 11:00
My version is Ubuntu Precise(12.04), and what I should do for this version? Thanks! – feelfree Dec 18 '12 at 12:20
Although I can't find an explicit statement anywhere, it looks like it has been deprecated for some time, replaced by postscript support in KDE's okular PDF and other document viewer. – chronitis Dec 18 '12 at 12:32

You should use the package manager to install programs. If you are on hardy(the last version with that package, think it was replaced by okular in later versions) you should be able to install the kghostview with this command and get all dependencies:

sudo apt-get install kghostview

Otherwise install the dependencies:

sudo apt-get install libqt3-mt kdelibs4c2a
sudo dpkg -i kghostview_3.5.10-0ubuntu1~hardy1.1_i386.deb
share|improve this answer
Thanks, and I tried to install as you suggested but failed. My Ubuntu's version is 12.04(precise), and it does not work for this version. – feelfree Dec 18 '12 at 12:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.