Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 last week. Now I want to use Windows 7 on Ubuntu via Virtualbox. I installed the Virtualbox and created a new machine namely 'windows 7'. I'm booting through an ISO image. When I start the virtual machine it does not run. It gives the following 2 errors:

"Failed to open a session for the virtual machine mint.
The virtual machine 'mint' has terminated unexpectedly during startup with exit code 1.
Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Machine
Interface: 
IMachine {5eaa9319-62fc-4b0a-843c-0cb1940f8a91}".

and

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary."

I have no idea that how to fix it. I tried running other OS as well like Linux Mint 12 but same error occurs. Please help!!!!

share|improve this question
1  
You have probably received an update of your kernel, so you need to install vbox kernel modules to it. Have you tried running, what it says: sudo /etc/init.d/vboxdrv setup? –  Pavel A Dec 18 '12 at 9:16
    
Can you help he intalling the vbox kernel modules? I already tried the command you said but it gives an error sudo: /etc/init.d/vboxdrv: command not found –  Muhammad Usama Dec 18 '12 at 10:58
    
strange output. Please edit your post and copy-paste everything there is on terminal when you run this command including command itself. –  Pavel A Dec 18 '12 at 11:14
    
me@delta:~$ sudo /etc/init.d/vboxdrv setup sudo: /etc/init.d/vboxdrv: command not found me@delta:~$ –  Muhammad Usama Dec 18 '12 at 11:16
    
i can't reproduce the issue. Maybe VirtualBox installation is corrupt - try removing it and reinstalling using Software Center or with a package from official site. –  Pavel A Dec 18 '12 at 11:23

2 Answers 2

Seems to be a known issue. Try to install VirtualBox from the Oracle binaries directly: https://www.virtualbox.org/wiki/Linux_Downloads

sources: http://ubuntuforums.org/showthread.php?t=1739768

share|improve this answer

had the same issue a while ago, so please check the following:

  1. Check the BIOS settings and enable something called "Intel Virtualisation Technology" if you have an Intel CPU, or any other setting that reffers to vitualisation, CPU pass through.

  2. Make sure you leave the default setting for the virtual machine as Oracle VB sets them.

  3. Remove the currently installed VB, and try the one on the official website.

In my case I had to install the VB from the website, issue solved.

Please post an answer and let know if anything worked. Take care.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.