Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not sure what I've done, but when I click the Banshee icon in the menu, the starting Banshee button appears for a few seconds in the taskbar at the bottom, then disappears.

I'm running 10.04 lucid by the way.

If I try to start it using the command line, I just get a blinking cursor.

I can start it as root, but it advises me to move my music to root's home directory, but I don't want to run it as root anyway.

I've tried re-installing, upgrading to a newer version, reverting back to an older version etc, all to no avail. I've tried deleting all the config files etc, but nothing works.

If I log in as another user it works, so I know it's something in the config, but I just can't work out what.

Can anybody help?

Thanks in advance

share|improve this question
1  
One way to solve the problem is to delete the banshee config file and folder. This would DELETE all your personal settings and playlist, restart the bansee. –  Amey Jah Dec 18 '12 at 6:03
    
If you run banshee --debug from the terminal, it should give more useful output, which might contain a clue about the problem. –  michaelms Dec 18 '12 at 12:45
    
Tried debug, and this is what it says: –  Geoff Cooper Dec 18 '12 at 14:27
    
geoff@Qube:~$ banshee --debug ** Running Mono with --debug ** [1 Debug 15:03:34.257] Bus.Session.RequestName ('org.bansheeproject.Banshee') replied with InQueue this is followed by a blinking cursor. –  Geoff Cooper Dec 18 '12 at 14:27

2 Answers 2

Here is two step workouts to this...

Go to your home folder, hit Ctrl+h to view dotted (hidden) files.
Alternatively go to menu >> View >> Show hidden files

Then search for the folder .config open it and search for .banshee Delete the folder .banshee

Then throw up the terminal : Ctrl+Alt+t issue these commands one by one

sudo apt-get purge banshee
sudo apt-get remove banshee
sudo apt-get install banshee
share|improve this answer
    
Thanks for your prompt reply, unfortunately it didn't work. –  Geoff Cooper Dec 18 '12 at 13:02
    
this boggs me lil'bit.. clearing the folder from .config and re installing the applications always works ! –  Z9iT Dec 19 '12 at 16:20
1  
It boggs me too @Z9iT I've tried all of the suggestions listed above and none of them work. I've tried running it with the --debug option and posted the results above but so far no reply. Thanks anyway. –  Geoff Cooper Dec 19 '12 at 19:15

If you want to remove an app totally, including its configuration files, here is the command that you may use in a terminal (Ctrl+Alt+t):

sudo apt-get purge banshee

Then you can try reinstalling Banshee, from the Ubuntu Software Center for instance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.