Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My first post here.

Clean install of 12.04.1. Previously 10.04. Have been running a p2035n printer without problem.

Now, no matter what paper tray I select it prints to the top "by-pass" feeder--not the lower main tray. And when I select to print to manual feed, it does not wait for me to put in paper (like it used to), but prints immediately.

The printer is on a samba share and is physically plugged into a WinXP machine. Its uri is smb:///computername/p2035n.

I have tried several of the offered drivers for this hp machine, and even tried generic-laser. Same result on all.

Here are some other things I have tried (losing 2-3 hours of my time!):

hp-check -t reports “error: User needs to be member of group 'lp' to enable print, scan & fax. ” and “warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP.”

needed to download HPLIP 3.12.11


sh hplip-3.12.11-run

says that before setup logout and then on login run hp-setup

hp-setup could not find the printer

ran hp-check -t again, found I was not in group lp

ran hp-check --fix and it fixed that problem, asks for reboot

rebooted after running update manager (new kernel) and hp-check -t shows no errors this time

all the tray selections end up on the bypass tray

hp-setup still cannot find the printer

So is there a way to make this work?


:- Doug.

share|improve this question
try using localhost:631 in your browser and setting it using the administrator tab – Ringtail Dec 18 '12 at 3:24

I would suggest opening a terminal and issue this command sudo apt-get install hplip-gui This package contains utilities with graphical user interface (GUI) for HPLIP: HP Toolbox, HP Fax etc.

share|improve this answer
Rick Green-- Thanks for your response. This gui reports No installed hp devices found. I tried the cups web interface and the printer shows up, but I do not see anything I can do to modify it. The gui says only devices installed with the hp: or hpfax: cups backend will appear in the manager. Not sure what to do for that. – dgermann Dec 19 '12 at 2:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.