Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to set via my Media Keys, so I first have to find out the terminal-command.

Outputs are:

amixer set Master 10%- amixer: Unable to find simple control 'Master',0

amixer scontrols Simple mixer control 'IEC958',0

amixer set 'IEC958' 50%- amixer: Invalid command!

How can i fix that?

share|improve this question
Has nobody an idea? – Paul Woitaschek Dec 19 '12 at 14:15
You will find an answer to your problem in this Q&A – danjjl Dec 20 '12 at 17:08
I read that, but do not really know what to do now. I mean the normal sound control is working. I have a icon in my panel with which I can control the sound. Also I'm asking myself how to configure the xfce4-volumed. It recognizes my mediakeys, but it changes the wrong soundcard, where the xfce4-mixer controls the right soundcard. – Paul Woitaschek Dec 20 '12 at 17:14
I had the exact same problem and changing the active card in the settings editor for xfce4-mixer solved my problem. – danjjl Dec 20 '12 at 17:34
Now the keys work, muting works, but unmuting not. How can I fix that? – Paul Woitaschek Dec 20 '12 at 21:00

If the packages xfce4-mixer and xfce4-volumed are installed you shouldn't have any problem:


This is the frontend for mixer settings delivered together with the Xfce4 desktop environment. It does the same jobs other mixer frontends do but is integrated into the Xfce4 desktop as a plugin for the Xfce4 main panel.


This is a volume keys control daemon for Xfce Desktop environment. It controls the volume using multimedia keys, for the card configured in xfce4-mixer. It also provides volume change notifications.

Edit: I was also searching for a definitive answer and ran across this which also lead me to see this

Now, the problem "Volumed points to sound card, and when I mute with Fn+keyboard, it mutes pulseaudio but cannot unmute it"!

So this issue was Solved using this application PULSEMIXER

share|improve this answer
Both are installed, but it doesnt work. I see in the popup-are the volumebar twice changing, but it doesn't affect my sound. – Paul Woitaschek Dec 18 '12 at 14:23

You might try the command

$ amixer -c 1 set Master 10%-

The parameter -c specifes another audio card.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.