Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I followed instructions from serveral pages (e.g. here) to install Canon ip2600 printer drivers that were discussed for Ubuntu 12.04 or earlier as follows:

sudo add-apt-repository ppa:michael-gruz/canon
sudo apt-get update
sudo apt-get install cnijfilter-ip2600series

After that, the printer is listed and a printer properties window can be open. Trying to print anything fails with a message "Processing - Waiting for printer to become available." next to printer state.

Does anybody know how to get the printer to work? I am running Ubuntu 12.10 on 64 bit.

share|improve this question

After updating to Ubuntu 13.04 (64-bit), I got my Canon ip2600 printer to work with the canon-trunk repository:

sudo add-apt-repository ppa:michael-gruz/canon-trunk
sudo apt-get update
sudo apt-get install cnijfilter-ip2600series

Before that, I also tried the Gutenprint driver, which installed fine, but still no reaction from the printer.

share|improve this answer

I just installed Ubuntu on my ThinkPad X61 and Acer Aspire circa 2010; tried many wats but the following worked:

sudo add-apt-repository ppa:michael-gruz/canon-stable
sudo apt-get update
sudo apt-get install cnijfilter-ip2600series
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.