Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just bought a new laptop (a lenovo ideapad Z500) and it came installed with Windows 8. I wanted to have Ubuntu on it too, therefore I resized the Win8 partition from the control panel and installed Ubuntu on the free space I created. Ubuntu works perfectly, Windows does not load anymore... I tried the recommended repair with Boot-Repair but it did not fix, now I get a "Windows boot loader failed to start" on startup and then I get the GRUB screen. The partition summery created by Boot-Repair is here: How can I fix this? Thanks in advance for your help.

Edit: some more info after trying this for yet another. It looks like I'm not the only one having troubles with this, it seems that the whole Lenovo Z series is affected by this. I tried so far:

  • I've followed this guide: I could not get the Live CD to boot. Tried the same with Live USB, no luck. The CD is not detected as a bootable device, the PC keeps rebooting with the live USB inserted.

  • I've also tried this guide: http: //

No luck either, I get the Win 8 boot loader but I get an error message whenever I try to launch ubuntu UNLESS I accessed the BIOS and altered the boot order, in order to have Ubuntu on top of the list. This way I can access Ubuntu but not Win 8, unless alter the boot order again...

  • Standard install from CD. After the installation completed I could not get Win 8 to boot anymore. Used boot-repair and I still had could not get Win 8 to boot.

Still looking for an acceptable solution, thanks for your help.

share|improve this question
did you disabled UEFI for installing ubuntu? then you might need to reinstall windows 8 – Web-E Dec 17 '12 at 9:28
No I didn't... But I still can't boot Win 8 after installing ubuntu. – Gian Luca Scoccia Dec 18 '12 at 20:19
Please disable SecureBoot (and FastBoot) in your BIOS, then run Boot-Repair again, and indicate the new URL. – LovinBuntu Dec 18 '12 at 22:24
are you running 32 or 64 bit ubuntu? – don.joey Dec 21 '12 at 14:49
up vote 1 down vote accepted

Tried the whole process with Secure Boot and Fast Boot disabled, ran Boot-Repair after installing Ubuntu and now I can get to Windows 8 by choosing "Windows UEFI Recovery" on GRUB. I think, but I'm not sure; that Boot Repair was updated in the meantime.

share|improve this answer

try using an windows 8 cd and boot it up and check if it has an repair feature,it should have it,and then repair it.Something similar happened to me with windows 7 and repaired it with my windows 7 installation disc.

share|improve this answer
I do not have a Windows 8 cd, since it is pre-installed in a rescue partition. I can only restore the PC to it's initial state (but then I lose the Ubuntu partition). – Gian Luca Scoccia Dec 18 '12 at 20:36
Actually, I think it does not delete the data from the ubuntu partition, but I do not get to choose which OS to boot anymore... – Gian Luca Scoccia Dec 18 '12 at 20:42

Try the menu entry "Windows Recovery Environment (loader)". This is the boot loader which is stored in the EFI system partition and might work better than booting Windows 8 directly from its partition...

share|improve this answer
I tried and it did not help. – Gian Luca Scoccia Dec 18 '12 at 20:23
See my blog post about this topic:… Are you in Secure Boot Mode? – falstaff Dec 19 '12 at 8:34

You're going to have to redo the Windows boot loader. More help here:

Note: So far Windows 8 and Linux is problematic with the Secure Boot features. Expect bugs.

share|improve this answer

I guess we both have (just had) the same issue. I am afraid we installed Ubuntu's bootloader over Windows 8's bootloader. Since "Windows hates Linux" and due to "secure boot tech" we got ourselves in a damn trouble. Here's a way to make each bootloader work correctly and separately from the other.

The Windows loader is installed on the first partition (disk 0 partition 1) of your hard disk. What has gone wrong is that we installed Ubuntu's boot loader also over the same partition. The solution is:

  1. You should format that partition (surf the net first) this way both loaders are deleted.
  2. Install Windows 8 normally.
  3. Install Ubuntu and be sure not to install the bootloader on partition 0.

P.S. Deleting partition 0 might get u another problem please do more researches about it.

share|improve this answer
Please note device 0 partition 0 is 'disk 0 partition 1' sorry for the mistake – Mohammed Qaddoura Jul 19 '13 at 1:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.