Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just wanted to create a separate home partition on my Ubuntu 12.10 system. I booted the liveDVD, resized the sda2 partition (28gb of data resized to 30gb based on MiB [originally on a 100gb partition]) and made a new ext4 partition for the home folder. The drive is an SSD drive. I had changed the settings (noatime etc.) for SSD succesfully a week ago. On reboot I get the following error:

/dev/sda2 contains a filesystem with errors
Inode 74669 has an invalid extent node (blk 6881289)
fsd / [953] terminated with status 4

I was following this HOWTO, but I did not get to changing any of the files or configs other than those with gparted.

I have a (two-week old) SSD Samsung drive which is functioning just fine. Other specs: 64bit 12.10, i7, 8gb ram, nvidia.

UPDATE: When trying to recover the data in my encrypted home folder before a clean install I ran dmesg. The following things I do not understand, do you?

  • fb: conflicting fb hw usage inteldrmfb vs EFI VGA - removing generic driver
  • ACPI Warning: 0x0000000000000460 - 0x000000000000047f SystemIO conflicts with region VPMIO (20120320/utaddress-251)
  • ACPI ... rather than the native driver
  • lpc_ich Resource conflict(s) found affecting iTCO_wdt

This message I get for about a 100 inodes:

Valid ecryptfs headers not found in file header region or xattr region, inode 99738

Is it a problem that I resized a partition which contains an encrypted folder?


The system was corrupt. It had to do with ecryptfs. See: eCryptfs: Input/output error. I reinstalled.

share|improve this question
up vote 0 down vote accepted

So you increased the size of sda2? A filesystem can live in a partition bigger than its size, but if you want take advantage of this additional size, you have to resize your filesystem. Gparted should have done this for you automatically. Usually this isn't a risky process... Did the Gparted operation went through without errors?

The mentioned block 6881289 is inside your partition size (at 26.25GiB) so this block should be just fine...

I would suggest to check your partition table again, did you move your sda2 partition? Is the partition than before? Try using fdisk and the command (p)print.

Then you should do a full fsck on that drive (run on the unmounted filesystem from a LiveCD). Scan for bad blocks using the -c option (-f for force, means even the fs is marked as clean and -v for verbose). If more errors appear, there is probably a hardware failure.

fsck -cvf /dev/sda2
share|improve this answer
Thanks for you answer. I did not increase sda, but this is not clear from my question. sda2 was a 100 gb partition, I trimmed down to a 30gb partition. Gparted did not complain in any way. I did not move the partition. – don.joey Dec 17 '12 at 10:14
I ran fsck -cvf /dev/sda2 yet this did not make a difference. Now my system boots, yet the login screen shows up and disappears continually. When I login unity does not load. Looks like my system is corrupted right? – don.joey Dec 17 '12 at 20:52
Any other suggestion? – don.joey Dec 18 '12 at 14:08
So your fsck run did not show up any problems? I guess the disappring login screen is a completly independent problem. – falstaff Dec 19 '12 at 8:38
Doing a new installation is probably the best solution. Or you could try to reinstall Ubuntu on the same partition:… – falstaff Dec 20 '12 at 11:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.