Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I install Ubuntu on my powerpc G5? which version do I download? where do I download it from? and how do I get it to install? I tried burning ubuntu powerpc 12.04 and booting from the cd and all I get is a DOS like setup prompt "boot:" I've tried 'live' and everything else listed when I push tab; but, every time I get a bunch of white text on black screen, then black text on white and then my monitor just goes black and nothing happens??? what am I doing wrong? any suggestions?

share|improve this question
Its now no longer supported on PPC Architecture. – Dean Dec 17 '12 at 2:19

Still attempting the install on your G5? I've got mine working--except for wireless.

Here's my experience.

When my screen went blank it was because I had two monitor cards installed. I got rid of the inactive one, and text appeared instead of going blank--as if to suggest that the installer was trying to write to the non-existent monitor. I don't know your setup, so I don't know if that's going to be a help or not. Think carefully about any virtual monitors that you may have created, or mirrored screens that you may have needed to set up for some reason. Maybe that'll jog your memory. HTH.

I had OS X 10.5.8 installed on a 2 TB drive. I used Disc Tools to adjust the partition to 1 TB (which you can do starting in 10.5.8 and up), and installed the Ubuntu PowerPC 12.04.01 version along side OS X in the remaining 1 TB partition.

I tried PowerPC Lubuntu (note the 'L' in Lubuntu) 12.10 with miserable results.

BTW, I also tried PowerPC 10.04 LTS and everything worked--everything.

However, upgrading from PowerPC 10.04 to 12.10 was a train wreck.

As I said, I've got both working--OS X 10.5.8 and PowerPC 12.04.01--although I'm still trying to track down the resolution of the wireless / Broadcom / B43 networking issue. I'm hoping that that won't take too long--we'll see.

The bootloader in use--yaboot--works great for Ubuntu, but not for OS X. If I want to boot OS X, I hold down the option key to get Apple's option page and choose OS X from there. Apparently, yaboot is passing incorrect or incomplete boot parameters to the OS and after about 30 seconds, yaboot --> OS X freezes. yaboot --> Linux works fine.

Doug Parker Orlando, FL

share|improve this answer

The Ubuntu Wiki has a bunch of stuff about installing Ubuntu on PowerPC, though I'm not quite sure when the last time it was updated.

Follow this doc for more information:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.