Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After having done a very long research, about this type of usb-modem, I'm here asking for your help. In my PC I have installed lubuntu (the version obtained from Ubuntu 12.04). In order to connect the USB-modem, I have to eject the usb-storage (that is firstly recognized by the system) and then, I can use the normal Gnome-NetworkManager tool. The problem is that I would avoid having, all the times, eject manually the inner USB-storage, configuring the system in order to proceed on ignoring the present storage and treat the USB-device only as a modem.

The included linux-setup tool, doesn't work properly (I have tried to install it, without success).

I have tried to configure usb_modeswitch, but I don't have enough informations (this version of USB-modem, is not included on the device-recognition files). To not mention that, at this time, the default vendor and product hex-ids are currently unknown at me. I barely managed to obtain the specific ids, running the command lsusb, but of course, without such informations, I can't proceed with the command, as the parameters are insufficient.

I thought to create a script file, that would umount the usb-storage part, then use modprobe and usb_modeswitch, in order to automate the connection setup, but I can't manage to umount anything (that the system seems to ignore my commands) and I can't proceed with the initialization.

There's a standard way to handle this situation accordingly?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.