Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Flush is a torrent client similar to Deluge or Qbittorrent, is the lightest, and I have used it along Qbittorrent without any problem for some time.

But after reinstalling the OS I used only Qbittorent for a while; now when I want to try Flush again I have a problem: after I install it, execute it, and see some action of the processor (i see that light flashing a few secs like when a program starts), but then nothing happens.

At first view, this looks similar to a problem reported in connection with FoxitReader, that I also encountered and solved according to the answer. It would have been similar, except that in the case of FoxitReader the program was absent in usr/bin, and putting it there manually after extracting it from deb solved the problem. In the case of Flush, it is already in usr/bin. I see it in Synaptic, in launcher, in menu, in run(alt-f2) and usr/bin: nothing works.

(In the case of FoxitReader, the program appeared in menu, launcher, and synaptic, but not in run and not in usr/bin.)

I have installed Flush from Synaptic (currently 0.9.12) and have also tried the deb version 0.9.10 with identical results.

(I'm in Lubuntu 12.04).

(The same happens when I try Frostwire.)

Edit after comment: after running flush in Terminal I get:

~$ flush
(flush:3711): GLib-WARNING **: /build/buildd/glib2.0-2.32.3/./glib/goption.c:2179: ignoring no-arg, optional-arg or filename flags (8) on option of arg-type 0 in entry main:version

(flush:3711): GLib-WARNING **: /build/buildd/glib2.0-2.32.3/./glib/goption.c:2179: ignoring no-arg, optional-arg or filename flags (16) on option of arg-type 4 in entry main:config

(flush:3711): GLib-WARNING **: /build/buildd/glib2.0-2.32.3/./glib/goption.c:2179: ignoring no-arg, optional-arg    or filename flags (8) on option of arg-type 0 in entry main:only-pass

flush: symbol lookup error: flush: undefined symbol: _ZN10libtorrent7sessionC1ERKNS_11fingerprintEii
share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted
+50

That seems to be a compiling/linking bug with flush: that undefined symbol is provided by libtorrent-rasterbar6, which seems to be installed.

So you can try to reinstall libtorrent-rasterbar6 and see if you get anything different:

sudo apt-get install --reinstall libtorrent-rasterbar6

Also, there is a PPA that seems to be maintained by the creator of Flush, and so it should be safe for you to try it:

sudo apt-get remove flush libtorrent-rasterbar6
sudo apt-add-repository ppa:konishchevdmitry/flush 
sudo apt-get update && sudo apt-get install flush

Hope this helps.

share|improve this answer
1  
i hope this will help the others, i have upgraded to 12.10 and flush started working. –  cipricus Dec 27 '12 at 16:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.