Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been backing up my home folder with Grsync for several years now. With the introduction of the legal confirmation in the Unity Dash (12.10) I am getting a file called 'unitydashlegalseen' in '/home/username/.cache/' that gives a permission error when syncing in Grsync. I googled and thought I could exclude this file in from syncing Grsync under Advanced options/Additional Options. The command I guessed is obviously wrong as it does not work, does somebody know what I correctly have to put in? This is the wrong command I used:

--exclude '/home/username/.cache/unitydashlegalseen'

share|improve this question
    
Just to confirm, did you replace 'username' with your actual username in the command? For example my username is 'tom', so I'd use the command /home/tom/.cache/unitydashlegalseen. –  Tom Brossman Dec 23 '12 at 10:39
1  
Actually I just edited the post 20 minutes before your comment and replaced my real username with "username" because I remember when I started to become a Linux user almost 3 years ago it was quite confusing to find so many different and strange things behind "home/" ;-) –  Consumology Dec 23 '12 at 10:47

1 Answer 1

up vote 3 down vote accepted

Ok, actually it is pretty easy, the answer is in the official Grsync forums: http://opbyte.freeforums.org/exclude-from-backup-won-t-work-t192.html

  1. Create a file called "exclude.txt" in the hidden folder /home/username/.grsync I did this via right clicking the specific folder in Nautilus and created a new file from the pop up menu. This way I avoided the problems described in the above thread where the problem seemed to be that it had been created with LibreOffice.

  2. Open the file with gedit and put in the paths you want to exclude from syncing. I put in these two: .local/share/Trash .cache/unitydashlegalseen

  3. In the Grsync select the correct Session and then go to Advanced Options/Additional Option where you put in the command linking to your exclusion list (as seen in the second screenshot in the above mentioned forum post): --exclude-from="/home/username/.grsync/exclude.txt"

  4. Mind to delete already synced files (listed in the exclusion list) on the remote location if you do not want them to be there (otherwise they remain as they have been before excluding them - e.g. with VirtualBox images this would save a lot of hard disk space on the remote location).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.