Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off, I'm not just a newbie, I'm clueless! So your answers will need to be in complete idiot language (let's say I'm computer savvy, and I can follow directions, but I've never programmed anything and assume I don't understand any abbreviations. So why am I running Linux? Because Windows was driving me nuts and my friend managed to convince me. day-to-day operations, we're doing fine, but when it comes to problems, I've got no clue what I'm doing!)

So here's what's going on, my machine is an HP pavilion dv6, my optical drive is a standard cd/dvdrw, when i load an audio cd of any type (burned, official, etc,..) I have no problems, when I pop in a dvd - i get nothing. the dvd icon comes up in my launch tray, when I open VLC player I can find the dvd in the folder... but it won't play. I can watch movies I've downloaded with no problem, I can also watch movies off an external hard drive.

The only thing I've tried is removing VLC and reinstalling, and I tried installing a different player (gnome maybe? I don't remember). However, none of them work.

Again, I can follow directions, but you need to be very specific and don't assume I know anything going in. (I mean, I know basic stuff, but nothing too technical.)

PLEASE HELP!!! MY KIDS ARE DRIVING ME CRAZY!!! Thanks!!

share|improve this question
    
Possible duplicate of: askubuntu.com/questions/500/how-can-i-play-encrypted-dvd-movies –  david6 Dec 16 '12 at 10:12
add comment

3 Answers

Try pointing VLC to /dev/sr0 instead of /dev/dvd when you open a DVD (CTRL+D). Also, did you install libdvdcss? https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

share|improve this answer
add comment

A reason for this could be that you have not installed the codecs for reading encrypted DVD's. Go to the Ubuntu Software Center and look for 'libdvdcss' and 'libdvdread4' and install them. As far as I know they are not installed by default, since it is based on closed source and therefore not in the philosophy of open-source software.

share|improve this answer
add comment

I know this is an old thread but i couldnt find a more up-to-date one, thaat i could reply on. I am running ubuntu 12.04 LTS, and couldnt get DVDs to run after reinstalling the operating system. I had installed the restricted extras and livbdvdcss, but it still wasnt working.

In the end I connected the screen via the graphics card and DVDs now play in VLC (but not movie player). The screen had been connected to the motherboard directly.

I am sure this isnt actually the solution to the problem, but the information might be useful to solving the problem.

Thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.