Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to install 'boot-repair' but it keeps saying:

The following packages have unmet dependencies: Depends: boot-sav (>= 3.196) but 3.196~ppa3~quantal is to be installed

E: Unable to correct problems, you have held broken packages.

When I try installing 'boot-sav', everything seems okay, but when I try it again, it just shows the same message over and over again. How can I fix such a problem?

Thanks.

share|improve this question
    
Oh, I guess it's a bug... . –  Chibueze Opata Dec 16 '12 at 6:28
    
try sudo apt-get install -f –  Web-E Dec 16 '12 at 7:27
add comment

2 Answers

I'm getting this error booting off the 12.10 live CD, and no amount of apt repair (including apt-get install -f) fixes it.

I get the same problem (substituting "precise" for "quantal" in the installed version of boot-sav) booting from the 12.04 LTS live CD.

But what should work, and I'm about to do, is to download the ubuntu-secure-remix CD and use that, as it has it already successfully installed.

https://help.ubuntu.com/community/UbuntuSecureRemix

There's an alternative out there that's slightly smaller (I've misplaced the link), but it doesn't support UEFI, while the 64-bit version of ubuntu-secure-remix does, and both versions are relatively up-to-date, being based on 12.10.

[Edit: And indeed, as expected, the CD did allow me to repair my boot setup.]

share|improve this answer
add comment

Bob Kerns answer is good. Another much cheaper(700% smaller) and effective alternative, the one I eventually used was to install and use grub-customizer...

The GUI is great and it seems to do the job better than any other boot fix utility.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.