Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New Ubuntu user - just recently made the mistake of trying a different nvidia driver. I'd managed to get the last (nvidia-current) one working through software sources a few weeks ago. The other day I tried to cross over to nvidia-experimental-310 and this produced a system error. Swapping back and forth between proprietary drivers now always causes an error and I can't get any of them to work.

Installing through the terminal I get this error message every time:

Building initial module for 3.5.0-19-generic
Error! Bad return status for module build on kernel: 3.5.0-19-generic (x86_64)
Consult /var/lib/dkms/nvidia-experimental-310/310.14/build/make.log for more information

On rebooting, I end up with the crappy screen resolution and the thick black border around the screen. I use gksudo software-properties-gtk to bring up sources, where I can change back to the nouveau driver, which restores my screen. After that I can't find /var/lib/dkms/nvidia-experimental-310/310.14/build/make.log so I can't tell you what's inside.

Any ideas what might be preventing the nvidia driver from installing?


SOLUTION FOUND Okay - so I have a workaround. This is what has worked:

  1. Upgrade to kernel 3.7.0 as detailed here
  2. upgrade to latest version of the nvidia drivers as detailed here

No idea what was happening with kernel 3.5.0-19, but this seems to be better. A little slower maybe on boot, but after days of messing around it's nice to have something that works.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.