Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This error prevents the system from upgrading to a newer version of Ubuntu, what is causing it?

 W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/natty/main/source/Sources      404  Not Found

 W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/natty/main/binary-amd64/Packages  404  Not Found

 E: Some index files failed to download. They have been ignored, or old ones used instead.

Since I got the warning message that this release is not supported anymore, should I download and install Ubuntu 12.10 directly from Ubuntu's site instead?

share|improve this question
    
The actual error is missing. Please run the following command in a terminal and provide the full output it produces: sudo apt-get update –  Dennis Kaarsemaker Dec 15 '12 at 21:02
    
@DennisKaarsemaker: Done. Thank you for your help. –  Gigili Dec 15 '12 at 21:15
add comment

1 Answer 1

up vote 0 down vote accepted

Fortunately it's only the extras repo that's not working. You can disable that in the software sources application or by editing the relevant file in /etc/apt. After that, the upgrade to 11.10 should work. It's also advisable to upgrade to 12.04 LTS after upgrading to 11.10 as 11.10 is only supported for a few more months and 12.04 LTS for at least 2 4 (see below) more years (and a few months).

share|improve this answer
    
Thank you for your answer, could you elaborate on how to disable it? –  Gigili Dec 15 '12 at 21:25
1  
12.04 LTS will be supported until April 2017. wiki.ubuntu.com/Releases –  fabricator4 Dec 15 '12 at 21:31
    
Each repository is listed in either /etc/apt/sources.list or in a file in /etc/apt/sources.list.d - to disable the usage of a repository, open the file in a text editor as root (gksudo gedit filename_goes_here) and place a # in front of the line you want to disable. Any line that mentions extras.ubuntu.com should be disabled. –  Dennis Kaarsemaker Dec 15 '12 at 21:31
    
@fabricator4 - ah, must have missed that change in release policy, thanks for the addition. –  Dennis Kaarsemaker Dec 15 '12 at 21:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.