Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently got a Zenbook Prime and installed ubuntu. Following The tips at https://help.ubuntu.com/community/AsusZenbook worked out pretty well.

Only one problem remains: I can not set the DPI. I tried to do xrandr --dpi 138/eDP1 but that doesn't seem to have the desired effect. It changes the output of xdpyinfo |grep resolution but no change is visible. Also, xrandr still reports the same screen size.

I tried adding Xft.dpi: 138 to .Xresources, which didn't change anything.

I also tried to generate a xorg.conf, where I set

Option       "DPI" "138 x 138"

in the monitor section. The Xorg.0.log then tells me

(==) intel(0): DPI set to (96, 96)
...
(WW) intel(0): Option "DPI" is not used

I have no idea what else to try and it doesn't seem any one else has the same problem :(

Any help would be much appreciated.

PS: I know that it is possible to zoom fonts, but I'd rather actually set the DPI of the screen.

share|improve this question
add comment

1 Answer 1

I am not entirely sure if this is what you want, but as a workaround you can use Ubuntu Tweak's 'Font scaling' tweak to change the dpi of the fonts in your GUI, thus resizing a lot of elements and therefore having more screen real estate.

share|improve this answer
    
This is the workaround that I am currently using but it is not a real solution imho. –  Andreas Mueller Apr 1 '13 at 11:55
2  
Andreas, did you find a solution. I am too trying to do the same. –  Vivek Sharma Apr 15 '13 at 3:50
    
@AndreasMueller Did you solve it? Trying same. –  umpirsky Jun 11 at 15:34
    
None, I did not :-/ –  Andreas Mueller Jun 12 at 9:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.