Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed 10.04, and used manual partitioning to preserve my '/home' from a 9.04 install. (To be clear: I did not upgraded 9.04 to 10.04, but installed 10.04 off a of CD, keeping only my '/home'.) After the sucessful 10.04 install, I used synaptic to apply all updates, rebooted, removed some packages (mostly tomboy and bluetooth), rebooted, and then used synaptic to install tonnes of packages, mostly from lucid/main and lucid-updates/main, though I also did install a number from lucid/universe and lucid-updates/universe.

A minute or so after the mass installation of new packages, a red circular icon with a white bar running horizontally through it appeared in my notification area. (The icon is quite like the "Do not enter this road" sign pictured here.) On hovering my mouse over the icon, I get the following message:

An error occurred, please run Package Manager from the right-click menu or apt-get in a terminal to see what is wrong. The error message was: 'Unknown Error: '' (E:Opening configuration file /etc/apt/apt.conf.d/99synaptic - ifstream::ifstream (13: Permission denied))' This usually means that your installed packages have unmet dependencies

(Since there was no way to copy the text, I transcribed it; it isn't impossible that it is not a completely faithful transcription.)

I then ran the following commands:

  1. sudo apt-get check
  2. sudo apt-get clean
  3. sudo apt-get autoclean
  4. sudo apt-get autoremove

and then ran those same commands (in that order) but also with the -f flag. I then rebooted. This hasn't removed the warning icon from the notification area. So, I am at a loss for how to proceed.

[Snip a lot of detail about what packages I'd installed and removed that turned out not to be relevant at all.]

share|improve this question
    
When you say you use synaptic to apply all updates, do you mean after the new installation of 10.04? –  txwikinger Aug 14 '10 at 22:12
    
@txwikinger: Yes. Off to edit to make that clear in the question. –  vanden Aug 14 '10 at 22:21
    
Can you post what is in the file /etc/apt/apt.conf.d/99synaptic you can find it by pressing Alt+F2 and then typing gksudo gedit /etc/apt/apt.conf.d/99synaptic Please post it to pastebin.com and link it back to there ;) –  Source Lab Aug 14 '10 at 23:04
    
@Source Lab: See my comment on @Oli's answer if interested. The file has almost no contents and it was a silly permissions problem. –  vanden Aug 15 '10 at 1:56
add comment

1 Answer 1

up vote 2 down vote accepted

This should fix the permission problem (from this thread):

sudo chmod o+r /etc/apt/apt.conf.d/99synaptic

But usually if you have broken dependencies you'd look in synaptic, aptitude or fire off:

sudo dpkg --configure -a
share|improve this answer
    
Doing ls -l /etc/apt/apt.conf.d/ revealed that all files in that dir had root:root ownership and rw-r--r-- permissions, save /etc/apt/apt.conf.d/99synaptic. Running sudo chmod a+r /etc/apt/apt.conf.d/99synaptic fixed the problem as in @Oli's link. 99synaptic has a single line APT::Install-Recommends "true";. It's not at all clear why this needs to be world readable for things to function smoothly, nor why the permissions on 99synaptic should have been different than those of the other files in the dir. But, problem solved! Thanks! –  vanden Aug 15 '10 at 2:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.