Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was playing with grub on my computer a bit more. Then I tried to reboot and I can't enter my operating systems (windows and Ubuntu). It looks like I've rewritten something very important because it only shows me grub command line and I don't know how it boot. I've tried to set root and then load vmlinuz, but it tells me that I need to specify some root option correctly. I was doing a lot of things with grub and I don't remember every think. I just remember that I tried something like grub-mkconfig recheck. I was also editing grub.cfg. I have also tried to read grub.cfg by cat and it looks normally.

share|improve this question

closed as not a real question by Tom Brossman, Ringtail, hhlp, fossfreedom Dec 16 '12 at 0:31

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

I've proceed a bit. I'm now in kernek but I can still use only bash. – user35443 Dec 15 '12 at 15:01
up vote 4 down vote accepted

Have you tried to boot with a LiveCD, and fix with Boot-Repair?

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair


It is straightforward to use, and worked for me before. basic UI

and it allows yo to change kernel options as well: advance UI

share|improve this answer
Thank you alot. It works perfectly now. – user35443 Dec 15 '12 at 15:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.