Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

My laptop is: "Lenovo G580" and it comes with a very sensitive touchpad. Specially, when I place my hands comfortably to type, it "thinks" I'm touching the top-left corner. This becomes really annoying when I have to use both (the keyboard and touchpad), as it thinks I'm performing a 2 finger click (the mouse stop moving). I have disabled the 2 finger click, which defaults to right click, in order to prevent the right-click-menu randomly (imagine that!).

Using Xubuntu 12.10. These are my settings:

LeftEdge                = 2300
RightEdge               = 5000
TopEdge                 = 1652
BottomEdge              = 4658
FingerLow               = 25
FingerHigh              = 30
FingerPress             = 256
MaxTapTime              = 180
MaxTapMove              = 242
MaxDoubleTapTime        = 180
SingleTapTimeout        = 180
ClickTime               = 100
FastTaps                = 0
EmulateMidButtonTime    = 75
EmulateTwoFingerMinZ    = 282
EmulateTwoFingerMinW    = 7
VertScrollDelta         = 110
HorizScrollDelta        = 110
VertEdgeScroll          = 0
HorizEdgeScroll         = 0
CornerCoasting          = 0
VertTwoFingerScroll     = 1
HorizTwoFingerScroll    = 0
MinSpeed                = 1
MaxSpeed                = 1.75
AccelFactor             = 0.036324
TrackstickSpeed         = 40
EdgeMotionMinZ          = 30
EdgeMotionMaxZ          = 160
EdgeMotionMinSpeed      = 1
EdgeMotionMaxSpeed      = 440
EdgeMotionUseAlways     = 0
TouchpadOff             = 0
LockedDrags             = 0
LockedDragTimeout       = 5000
RTCornerButton          = 0
RBCornerButton          = 0
LTCornerButton          = 0
LBCornerButton          = 0
TapButton1              = 1
TapButton2              = 0
TapButton3              = 2
ClickFinger1            = 1
ClickFinger2            = 1
ClickFinger3            = 0
CircularScrolling       = 0
CircScrollDelta         = 0.1
CircScrollTrigger       = 0
CircularPad             = 1
PalmDetect              = 0
PalmMinWidth            = 10
PalmMinZ                = 200
CoastingSpeed           = 20
CoastingFriction        = 50
PressureMotionMinZ      = 30
PressureMotionMaxZ      = 160
PressureMotionMinFactor = 1
PressureMotionMaxFactor = 1
ResolutionDetect        = 1
GrabEventDevice         = 1
TapAndDragGesture       = 1
AreaLeftEdge            = 0
AreaRightEdge           = 0
AreaTopEdge             = 0
AreaBottomEdge          = 0
HorizHysteresis         = 8
VertHysteresis          = 8
ClickPad                = 0

What I have tried:

1) The "CircularPad" option could solve my problem, but for some reason it doesn't work :(

2) Palm detection seems to fail as well... (currently disabled)

3) The "Block touchpad while typing" option resulted annoying as well, as I often use both input methods at the same time (like when you are searching for a file in a directory and type part of its name, and then clicking on the correct file). With that option, I have to wait about 3 secs in order to be able to use the touchpad, which I think is too much.

4) I could disable 2-finger scroll, but I use it a lot.

5) I thought that changing the Edges could be the easy way to go. I checked X and Y values in: "synclient -m 100" , and change the LeftEdge and RightEdge values as shown above. But even after setting them (using synclient LeftEdge=...) the cursor still moves below the LeftEdge and after the RightEdge, what am I doing wrong?

It seems that many options have no effect (like TapAndDragGesture), while changing others do (like setting 3 finger middle-click, etc.). Is that possible?

What other alternatives could I try to solve it? Thanks in advance!

share|improve this question

marked as duplicate by lepe, Eric Carvalho, Videonauth, David Foerster, Ron May 17 at 8:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 2 down vote accepted

After so many years, finally I solved. The trick was to set these settings:

synclient PalmDetect=1
synclient PalmMinWidth=10
synclient PalmMinZ=0

This answer helped: Touchpad palm sensitivity

UPDATE

The above settings solve part of the problem, as the cursor still jumps randomly while you are typing (very annoying). By chance, I found out that the following settings removed that behavior:

synclient AreaLeftEdge=2000
synclient AreaRightEdge=5000

Note: those are the settings for my device... you need to find out your device values.

Try incrementing AreaRightEdge starting from zero until you can move the cursor as "normal". AreaLeftEdge works the opposite, so from zero, increment it until it doesn't move... then go back little by little until the cursor moves as "normal" again. (at the end, AreaRightEdge can not be lower than AreaLeftEdge).

And to save the settings, follow this: How do I make my synclient settings stick? - Ubuntu 13.04

share|improve this answer
    
I simply do : synclient TapButton2=0; – userDepth Jun 13 at 15:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.