Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

New Asus n56vm laptop with an SSD (Samsumg 830) installed instead of the HDD it came with.

Ubuntu is the only OS installed on it and its installed in EFI mode.

The problem is that it will boot maybe 9 out of 10 times if an USB device (such as a mouse) is connected before powering up. If no mouse then it will 9 out of 10 times hang right after the grub menu (saying "Loading initial ramdisk").

No logs are beeing written to /var/log so there's nothing to google on, I've experimented with with booting into rescue mode, setting/unsetting several grub flags (noacpi, disable graphical boot etc) but nothing has worked so far.

In the bios I can see 2 boot options of the SDD (2 ubuntu with identical names). Booting of the second in the list reverses the issue above (9 out of 10 times it will boot without the mouse attached).

I've tried this fix: which kind of touches on the subject (but did not solve the issue).

I have run boot-repair on it, and when I did a third boot option off the hard disk appeared, but still the same behaviour as above.

Aany hints on how to solve this?

share|improve this question
up vote 2 down vote accepted

It seems to be working now. Here's what I did though not sure what caused it to work:

I flashed the BIOS from v204 (was default this from factory) to the latest 214 here. The bootup splash image is set to static.

Did not do this myself but the current kernel is 3.5.0-21-generic

share|improve this answer

I have three ideas about this, all of them very tentative/speculative:

  • This could be a kernel (or kernel driver) bug, in which case you'll need to wait for an updated kernel, or perhaps hunt down a new one that includes a fix and compile it yourself.
  • If you're booting with Secure Boot active, try disabling it. Ubuntu's Secure Boot support is very new, and could well have bugs that aren't well-understood, much less fixed.
  • You could try another boot loader. Several are available. I recommend trying either ELILO or the kernel's EFI stub loader (probably with the help of either rEFInd or gummiboot). Most of these options will require either disabling Secure Boot or jumping through some extra hoops to get your desired solution to boot with the help of a version of shim that Ubuntu doesn't yet provide.
share|improve this answer
Thanks for your reply - did try these, but I'm guessing it was the bios (or uefi I guess) firmware this time. – jonasl Jan 5 '13 at 20:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.