Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I am typing in Arabic, the cursor skips to the beginning of the line because if it were written from left to right, that would be where I last typed.

How can I fix that?

share|improve this question
2  
can you tell me this problem happened with which software exactly. As far as I know, there is not a problem with Ubuntu and Arabic support. the problem can be with your browser, if it was Google chrome or chromium, or specifies software you are using. –  aziz joh Jan 23 '11 at 18:37
add comment

1 Answer

Your software is considering the space character to be ltr and text rtl. In this situation the jumping cursor behavior is correct, at least according these bidi guidelines (section 24 which is ... educational). Thus, you need to instruct your software to insert the space at the correct bidi level.

For OpenOffice.org I found these instructions to work, even though they are quite old. In short, go to Tools > Options, select Language Settings > Languages and in Enhanced language support turn on Enabled for complex text layout (CTL). Now you should see the LTR and RTL paragraph icons on the toolbar (to the right of the text justification icons), choose the one that works for your text.

Other software might not have this setting available (I couldn't find anything for firefox). The trick mentioned in the previous link should work (adding the non-visible RLM character U+200F), but this is probably too cumbersome in practice.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.