Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every other browser installed is working fine, but Firefox will not connect to the internet. What do I need to check to make Firefox work on my computer? I am new to Ubuntu. I searched the web, but could not find enough clear information.

This is the error message that I am getting just before launching the application:

Could not initialize the application's security component. The most likely cause is problems with files in your application's profile directory. Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the application and fix the problem. If you continue to use this session, you might see incorrect application behaviour when accessing security features.

share|improve this question
what happens if you do sudo firefox in a terminal? – MDeSchaepmeester Dec 15 '12 at 11:24
It got installed successfully, but when I try to launch the application showing the above error – Chella Dec 15 '12 at 11:25
  1. Reset your firefox The reset feature works by creating a new profile folder for you while saving your:Bookmarks,Browsing history,Passwords,Cookies,Web form auto-fill information.Your original will be lost.
  2. Troubleshooting by yourself for a long time

EDIT Use safemode,choose reset button

firefox -safe-mode

or Use profile manager,type in terminal:

firefox -p
share|improve this answer
He can't start Firefox, so he'll never be able to reset it by the way showed on your link. – Farid Dec 15 '12 at 11:47
@Farid What about firefox -safe-mode? – yuan Dec 15 '12 at 12:02
Hey Thanks Zhang Yuan..! It is not solved my problem..drived me towards solving the problem..! Thank you..Now I resolved the issue..!I would have vote up but I don have enough reputation – Chella Dec 15 '12 at 12:22
@Chella,I'm willing to hear that you solve your problem.We are appreciate that if you can post your approaches. – yuan Dec 15 '12 at 12:29
1.I tried your advice "firefox -safe-mode" first(problem not solved) 2. then I typed firefox alone..! It asked me to reset the firefox completely, I chosen reset, restarted Firefox-> problem solved..! earlier I restarted firefox but not reset'ed – Chella Dec 15 '12 at 12:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.