Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 LTS yesterday from a usb, but it only boots into Windows unless the usb is in, then it boots into the Ubuntu loader where I can choose Ubuntu vs. Windows. What's the problem?

I run windows starter on a netbook with 1 gb ram and intel atom processor. I tried to install boot-repair but it won't work either. I follow the instructions for the Terminal and it seems to go right until I try launching it - then it says that it does not know the command boot-repair.

I really like Ubuntu, it lets this netbook run smoothly and better than ever before but I don't think I want to boot from a usb every time.

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

It seems you might have installed (1) Ubuntu or (2) Grub boot-loader or (3) both on your USB driver.

In the case of 1 and 3, you need to install Ubuntu again, making sure that it is installed in your fixed disk (e.g. sda2, sda3, etc. assuming Windows is on sda1) and also that Grub boot-loader is also installed in the same fixed disk.

In the case of 2, you need to install only Grub again from within Ubuntu. You can choose from a number of method for this, e.g. entering sudo grub-install /dev/sda in a terminal window.

share|improve this answer
add comment

I am a newbie to Ubuntu myself. But I think grub-customizer should help to solve the problem. Add the ppa for it, install and run it to check if there are menu entries for both Windows and Ubuntu.

I hope this is what you need :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.