Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My powertop reports this for the two audio codec components.

4.85 W    100.0%                      Device         Audio codec hwC0D3: Intel
4.85 W    100.0%                      Device         Audio codec hwC0D0: Realtek

I think 10 W for audio is too high. Can somebody please suggest me a way to reduce the power consumption?

It'd be nice if someone could educate me on this, I have an idea about codecs in general but I have no clue about their internals? Why is it that these two components keep running always even when I am not listening to audio?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Unfortunately this is a know bug as explained in:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/877560

Here you have a few workarounds (cited from the bug comments):

1. Manually force power save for the audio codec

Before proceeding, in a terminal launch the following:

cat /sys/module/snd_hda_intel/parameters/power_save*

if the result is different from:

1
Y

then try the following commands

echo 1 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
echo Y | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller
pkill pulseaudio

and then log out and log in again to get pulseaudio restarted.

2. Let the silence fall

If you mute your mic and your speakers, the device will be deactivate. It sounds strange, but it actually works for me.

3. Wait for Raring

According to the bug report, the problem is gone with kernel 3.7, and Raring will probably mount kernel 3.8.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.