Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After creating a custom keyboard layout, a table picturing the layout in a nice graphical representation was automatically created. It can be accessed from the keyboard icon. It opens in a separate window, cf. below:

enter image description here

However, this table isn't updated after making changes to an already existing layout (even not after rebooting). This is annoying, since now the picture doesn't correspond to the actual keyboard layout, but rather to the original one, before making any changes. It is just never updated after a keyboard layout is created with a new name.

Removing the keyboard layout from /usr/share/X11/xkb/symbols/ and creating it again doesn't help; the table seems to be cached somewhere.

I have no idea where this picture (or whatever it be) is saved, I don't even know what program creates it (it doesn't look too much like the ps-files created by xkbprint). Maybe deleting the table (not the keyboard layout) would do the job, but since I don't know where it is, I couldn't try.

I'd appreciate any hint on how I can force this table to be updated, so to fit my modified keyboard layout.

(I'm using Precise with Unity.)

share|improve this question

2 Answers 2

up vote 1 down vote accepted

A cache of (compiled) keyboard layouts is kept in the /var/lib/xkb/ directory, in the various *.xkm files. Perhaps deleting these files may help? There is a README in that directory giving a bit more information.

share|improve this answer
    
This looks promising, thanks @PLL ! I can't find the README, however... It's in the same directory, you say? –  lenz May 12 at 9:18
    
For me (running 14.04), yes, it is in the same directory: /var/lib/xkb/README.compiled. I don’t know if it exists in earlier releases, I’m afraid. In any case, though, you can (as I understand it) safely delete the *.xkm files; they are recreated the next time you visit the Tex Entry Settings panel. –  PLL May 12 at 11:12
1  
This is it! It worked! Deleting those did the trick. –  lenz May 12 at 15:27

AFAIK the only solution is to restart X server, either by re-logging in / rebooting, or by:

$ sudo restart lightdm
share|improve this answer
    
thanks, but neither rebooting nor restarting lightdm cause the layout table to update... –  lenz May 28 '13 at 22:50
1  
Sorry if I didn't help, I thought this would help. I'll look into it some more and let you know. For now I can only tell you that the keyboard chart is not an image, and it is not being cached anywhere, i.e. it is most definitely possible to change it. I'll just have to re-think about how to do it :) –  Томица Кораћ May 29 '13 at 6:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.