Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My brightness keys don't work on Ubuntu 12.10.
It's weird because they only worked 1 time, and I was like "I guess it fixed itself," but it hasn't worked since then..

I get this from in syslog:

Dec 14 16:14:08 toshi kernel: [ 2315.861338] atkbd serio0: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
Dec 14 16:14:08 toshi kernel: [ 2315.861342] atkbd serio0: Use 'setkeycodes e06e <keycode>' to make it known.
Dec 14 16:14:08 toshi kernel: [ 2315.934813] atkbd serio0: Unknown key released (translated set 2, code 0xee on isa0060/serio0).
Dec 14 16:14:08 toshi kernel: [ 2315.934817] atkbd serio0: Use 'setkeycodes e06e <keycode>' to make it known.
Dec 14 16:14:08 toshi kernel: [ 2316.097483] atkbd serio0: Unknown key released (translated set 2, code 0x55 on isa0060/serio0).
Dec 14 16:14:08 toshi kernel: [ 2316.097493] atkbd serio0: Use 'setkeycodes 55 <keycode>' to make it known.

Also it works to change brightness in Brightness and Lock but it's very inconvenient to have to use that.

share|improve this question
    
Have you tried the acpi_osi= as a kernel parameter via grub ? –  NikTh Dec 14 '12 at 21:35
    
The thing is the volume works [FN + 3, FN + 4]. So I know the FN button is working. but what do I put it equal to? acpi_osi=Linux ? –  Matt Dec 14 '12 at 22:00
    
The acpi_osi= is more effective , let the kernel decide the equal .. do not force it :-) . –  NikTh Dec 15 '12 at 4:19
    
Well I tried both ways and it did not fix it. I posted on ubuntuforums. –  Matt Dec 17 '12 at 3:34
    
Well , I cannot login to Ubuntuforums due to the recent problem with login (I have only a launchpad account) , so we cannot discuss it there. You can try another kernel or you can fill a bug about this. Probably a problem with ACPI. Usually such problems corrected with one of the above-mentioned parameters, but your situation seems little more difficult. –  NikTh Dec 17 '12 at 9:06
show 1 more comment

2 Answers

I would try changing the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" in /etc/default/grub.

Then run sudo update-grub.

share|improve this answer
    
I tried directly booting with those parameters by pressing E in GRUB, putting them after quiet splash but it did not work. I even tried acpi_osi= as in the comment by @NikTh, but that didn't work either. So today, before I tried this, after I resumed my laptop from suspend, the brightness keys worked! I rebooted and it stopped working. I tried sleeping, and waking up, it still did not work.. :( –  Matt Dec 16 '12 at 0:27
    
If you modify grub by pressing e, the settings are not permanent. If you modify grub the way I said in my answer the settings will be permanent. –  To Do Dec 16 '12 at 13:28
    
It would be no good to have it permanent, because it did not fix the problem. –  Matt Dec 17 '12 at 3:34
add comment

The messages in syslog point to the problem described here:
Finding raw scan codes - PS/2 keyboards
It is a long howto with much details.

The solution is tersely documented in the file:

/usr/share/doc/udev/README.keymap.txt.gz
share|improve this answer
    
thanks for the suggestion, however it did not work for me. :( –  Matt Mar 26 '13 at 16:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.